4

I have just installed Debian on a HP Envy laptop, with GNOME.

root@Cavalier:/home/jon# cat /etc/issue
Debian GNU/Linux 8 \n \l

root@Cavalier:/home/jon# lsb_release -a
No LSB modules are available.
Distributor ID: Debian
Description:    Debian GNU/Linux 8.6 (jessie)
Release:    8.6
Codename:   jessie

I am connected to the internet using a cable. I would like to connect via wifi.

I have a broadcom wifi adapter installed:

root@Cavalier:/home/jon# lspci | grep Wireless
08:00.0 Network controller: Broadcom Corporation BCM4352 802.11ac Wireless Network Adapter (rev 03)

There is an icon in the top right that tells me that it the "Wired" status is "Connected". But I can't see anything similar for wireless.

I have tried following the instructions here, but after logging out or rebooting, I don't see anything related to wireless in the top right.

I have tried running nm-applet, but get an error:

root@Cavalier:/home/jon# nm-applet

(nm-applet:2663): nm-applet-WARNING **: Failed to initialize D-Bus: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

What else can I try to get the wifi working

2 Answers 2

7
apt-get install linux-image-$(uname -r|sed 's,[^-]*-[^-]*-,,') linux-headers-$(uname -r|sed 's,[^-]*-[^-]*-,,') broadcom-sta-dkms
modprobe -r b44 b43 b43legacy ssb brcmsmac bcma
modprobe wl

https://wiki.debian.org/wl

4
  • Thank you Ipor. How did you know that? Is it related to the proprietary drivers? I was previously on LUbuntu, which appeared to automatically detect the proprietary drivers on installation.
    – Ginger
    Commented Oct 30, 2016 at 17:17
  • 2
    On ubuntu the driver is included in the kernel , On debian you need to add the non-free repo
    – GAD3R
    Commented Oct 30, 2016 at 17:19
  • Does the process above install CPU and GPU drivers too?
    – Ginger
    Commented Oct 30, 2016 at 17:24
  • you should get the info of your GPU and cpu , first , cat /proc/cpuinfo | grep 'model name' | uniq and lspci | grep -i 'vga'
    – GAD3R
    Commented Oct 30, 2016 at 17:32
2

According to deian-wiki you need to install the broadcom-sta-dkms packages then to load the wl driver

Add the non-free repository :

# Debian 8 "Jessie"
deb http://httpredir.debian.org/debian/ jessie main contrib non-free

Install broadcom-sta-dkms package and dependencies :

apt-get update
apt-get install linux-image-$(uname -r|sed 's,[^-]*-[^-]*-,,') linux-headers-$(uname -r|sed 's,[^-]*-[^-]*-,,') broadcom-sta-dkms

Unload conflicting drivers:

modprobe -r b44 b43 b43legacy ssb brcmsmac bcma

Load the wl module:

modprobe wl

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .