1

After switching from nouveau drivers to the Nvidia ones, my program crashes on start, saying that the swrast driver failed to load. The problem appears to be the drivers. I have the Nvidia drivers:

lib32-nvidia-libgl 375.10-2
lib32-nvidia-utils 375.10-2
libvdpau 1.1.1-2
libxnvctrl 375.10-1
nvdock 1.02-5
nvidia 375.10-1
nvidia-libgl 375.10-2
nvidia-settings 375.10-1
nvidia-utils 375.10-2
opencl-nvidia 375.10-2

LIBGL_DEBUG=verbose glxinfo gives some errors:

name of display: :0.0
libGL: screen 0 does not appear to be DRI2 capable
libGL: OpenDriver: trying /usr/lib/xorg/modules/dri/tls/swrast_dri.so
libGL: OpenDriver: trying /usr/lib/xorg/modules/dri/swrast_dri.so
libGL: Can't open configuration file /home/pengowen/.drirc: No such file or directory.
libGL: Can't open configuration file /home/pengowen/.drirc: No such file or directory.
libGL error: No matching fbConfigs or visuals found
libGL error: failed to load driver: swrast
X Error of failed request: GLXBadContext
Major opcode of failed request: 154 (GLX)
Minor opcode of failed request: 6 (X_GLXIsDirect)
Serial number of failed request: 48
Current serial number in output stream: 47

Some info:

uname -a:

Linux arch-pc 4.8.6-1-ARCH #1 SMP PREEMPT Mon Oct 31 18:51:30 CET 2016 x86_64 GNU/Linux

inxi -G:

Graphics: Card: NVIDIA GK110 [GeForce GTX 780] Display Server: X.Org 1.18.4 driver: nvidia Resolution: 1440x900@59.89hz GLX Renderer: N/A GLX Version: N/A

My X log (/var/log/Xorg.0.log) is here: http://pastebin.com/ediKiaXe

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.