i have some trouble with my Intel/AMD-GPU-Setup.

I am using a laptop with an "Intel Core i3-2350M 'Sandy Bridge'", which has the build-in iGPU "Intel HD 3000". In addition to this iGPU my laptop has the dGPU "AMD Radeon HD 6490M".

A few weeks ago i changed my system from Linux Mint 17.3 (Ubuntu 14.04-LTS-based, Kernel 3.19 with proprietary fglrx-driver) to Linux Mint 18.0 (Ubuntu 16.04-LTS-based, Kernel 4.4.0 with open-source radeon-driver).

With this new version of Mint/Ubuntu the AMD proprietary fglrx-driver with Catalyst Control Center is not supported and installable anymore and the dGPU is too old for the new amdgpu-driver. So my system is running on the radeon-driver now.

With the fglrx-driver and Catalyst Control Center i was able to activate and deactivate the AMD dGPU, depending on my use-cases, manually. With the radeon-driver now it's a bit different.

When i check my current GPU state with

$ sudo cat /sys/kernel/debug/vgaswitcheroo/switch

the result is always

1:DIS: :DynOff:0000:01:00.0

This means, that the iGPU is active and the dGPU is deactivated (by software/driver). Since i have (like all modern laptops) a muxless device, the entry 0:IGD looks good, but 1:DIS should change its state, when needed, to something like this

1:DIS: :DynPwr:0000:01:00.0

I found on this post

How to disable my APU and use the GPU (AMD Radeon) open source driver instead?

that i can force to use the AMD dGPU with a specific application (i.e. glxgears) like this

$ DRI_PRIME=1 glxgears

but not as the default GPU, used by the whole system (like with the Catalyst Control Center). Is this even possible (yet) with the open-source radeon-driver? And is there a way to use something like auto-GPU-switching (like, when the Intel iGPU has reached maximum load, the AMD dGPU will automatically be switched on) ?

Greetings and thanks in advance


try this

DRI_PRIME=1 glxgears -info

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.