0

I am running Ubuntu 16.04 on a laptop. I installed Virtual Machine Manager. How do I get a VM running for the first time?

I downloaded two different ISOs. I tried to create a VM with Virtual Machine Manager using each one. But the problem with each one was that they would not boot up. I would get

Booting from Hard Disk... Boot failed: not a bootable disk. No bootable device.

I have used .ISOs from trustworthy sources. One .iso was for QemuEmulator (https://help.ubuntu.com/community/Installation/QemuEmulator). Another .iso was to install Ubuntu directly on to a normal laptop. I used Virtual Machine Manager's GUI. I chose mostly the defaults or used articles I found online to create the VM. I had to do some troubleshooting just to see some output.

I tried using the virt-install command from a character prompt. But I had no luck there either. I tried using this command:

virt-install --connect qemu:///system --ram 512 -n foobar --os-type=linux --os-variant=debian8 --disk path=/root/debianfb.qcow2,device=virtio,format=qcow2 --vcpus=1 --graphics spice --noautoconsole --import --disk size=20

I tried variations of the above command. The results would show an error about the disk size must be specified for a non existent volume. debianfb.qcow2 is a non-existent volume. I thought this character-based way of creating VMs could borrow from the host OS. But I do not know the proper syntax to get it working. I am open to using either the GUI Virtual Machine Manager or a character prompt command like virt-install. What should I do?

I have not tried downloading a .qcow2 file. How would I know it is from a trustworthy source? I just want a basic VM on my Linux Mint laptop using KVM or QEMU.

  • you say “Booting from Hard Disk... Boot failed:…” this means it is trying to boot from the hard disk, not the ISO (ISO is a CD image). – ctrl-alt-delor Jan 18 '17 at 23:08
0

I'm not clear on how / if you explicitly created /root/debianfb.qcow2. If it doesn't exist then run:

qemu-img create -f /root/debianfb.qcow2 20G

If that is not the issue, you may be running into a problem I've experienced with Virtual Machine Manager (I'm not as familiar with 'virt-install'). Whenever I create a new virtual machine, even though I select the .iso installation medium during the install, the virtual CD drive is empty when I go to finish the install. So, make sure that the right .iso file is selected for "CDROM source path".

Then, under Boot Options, be sure that the CDROM entry is checked and that its the first entry in "Boot device order". Now try booting and good luck!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.