5

I have been using a Windows 10, Arch Linux, and Ubuntu triple boot for the last year without any problems. However, last week something weird started to happen. First, let me give the output of fdisk -lu

Disk /dev/sda: 931.5 GiB, 1000204886016 bytes, 1953525168 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: dos
Disk identifier: 0xd9fa2484

Device     Boot      Start        End   Sectors   Size Id Type
/dev/sda1             2048     206847    204800   100M  7 HPFS/NTFS/exFAT
/dev/sda2           206848  204802047 204595200  97.6G  7 HPFS/NTFS/exFAT
/dev/sda3        204802048 1023999999 819197952 390.6G  7 HPFS/NTFS/exFAT
/dev/sda4       1024004094 1953523711 929519618 443.2G  5 Extended
/dev/sda5       1024004096 1663361023 639356928 304.9G  7 HPFS/NTFS/exFAT
/dev/sda6       1663363072 1711697919  48334848    23G 83 Linux
/dev/sda7       1711699968 1774604287  62904320    30G 83 Linux
/dev/sda8  *    1774616576 1932972031 158355456  75.5G 83 Linux
/dev/sda9       1932986368 1953523711  20537344   9.8G 82 Linux swap / Solaris

Partition 4 does not start on physical sector boundary.

The /dev/sda4 is an extended partition and /dev/sda6 is my home partition for Arch (btrfs), /dev/sda7 is the Arch and /dev/sda8 is the Ubuntu installation. Both are ext4.

Recently, whenever I boot Windows, and then go back to any of the Linux distributions, I am greeted with an invalid superblock checksum error. I can run fsck and that fixes it without any data loss (or crucial loss), but it's a bit annoying to wait half an hour every time.

I have tried rebooting the Linux directly (without booting to Windows) and that is perfectly normal. This happens only if I boot Windows.

  • Which partition gives the error? Are you shutting down windows completely or just rebooting? Doesn't Windows have some sort of strange hibernate "feature" that doesn't properly shut down the machine? – terdon Oct 28 '16 at 12:36
  • @terdon the "strange" feature is just suspend-to-disk (s2disk), and the only reason it's strange is that it became the default meaning of "shutdown" in Windows 10. (I've turned it off in my organisation for all Windows clients, so that suspend means suspend and shutdown really does mean shutdown.) – roaima Oct 28 '16 at 12:43
  • @terdon I have it disabled for the last year. And yes, I shut it down completely. – Aniket Bhattacharyea Oct 28 '16 at 12:47
  • Version 0.69 fixed it: "1, FIXME: superblock corruption of EXT4 volumes with 64BIT mode enabled" – piegames Nov 26 '17 at 23:56
1

I have exactly the same problem than you.

And I found a solution :

The idea is to set offline the linux volume from Windows 10 the diskpart command is able to do that.

A detailed answer is here :

https://askubuntu.com/a/858159/619563

0

My guess would be as follows.

At some point you shrank the NTFS filesystem represented here as /dev/sda5 so that you had space to install Linux. That NTFS filesystem has not been shrunk correctly and its superblock equivalent still considers the full 440GB is available to it.

You need to run at least CHKDSK or TESTDISK to review and fix any mismatch between filesystem size vs partition size.

  • Weird part is that, as I said, I have this setup for one year. And it is behaving this weird since one week. The last time I shrank/expanded filesystem was one year ago. – Aniket Bhattacharyea Oct 28 '16 at 13:13
  • @AniketBhattacharyea so in the last week your filesystem content has overflowed the "safe" part of the NTFS filesystem and is now overwriting the other partitions. – roaima Oct 28 '16 at 13:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.