0

This -geometry 256x144+1095+600 work to show video in rigth bottom:

mplayer -ontop -noborder -geometry 256x144+1095+600 -loop 0 -idle -fixed-vo -msglevel all=-1 2>/dev/null video.mp4

enter image description here

But this one (-vo caca) always stay in same position with same width and height regardless of -geometry any_value:

mplayer -vo caca -ontop -noborder -geometry 256x144+1095+600 -loop 0 -idle -fixed-vo -msglevel all=-1 2>/dev/null video.mp4

enter image description here

My ultimate goal is display it in virtual console, so i wanted to know the equivalent format of -geometry for -vo caca. (It could be nice to know -vo fbdev too :)

1

Not all videodrivers in mplayer support the option -geometry.

I solved it for me with xfce4-terminal.

I had to export a Variable in .bashrc

CACA_DRIVER=ncurses export CACA_DRIVER

I start mplayer xfce4-terminal --geometry=+0+0 --hide-menubar --hide-toolbar --hide-borders -e "mplayer -vo caca -quiet Avatar.mp4" &

xfce4-terminal starts so left side top.

enter image description here Is this something you are looking for?

Sorry, I can not better explain in englisch.

Bahamut

  • I'm not sure why but it doesn't play in virtual konsole (Ctrl+Shift+N). And i can't make it always-on-top on gnome(I know it's not important because what's the point i use -vo caca while i already can access gnome) – 林果皞 Oct 29 '16 at 15:38
  • the Option -vo fbdev supported -geometry. It depends on the Modul for your graphics. lspci -nnk | grep "VGA\|'Kern'\|3D\|Display" -A2 But you mußt have the device /dev/fb0 or you get this message Can't open /dev/fb0: No such file or directory and you hear only audio-stream. I have only a german Link as source. – user192526 Oct 29 '16 at 16:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.