0

I´ve got a problem with firejail. In principle this sandbox works quite well. I can start a browser (firefox/midori) and other applications as well (like rhythmbox). What I want to do now is use the overlay-functionality: firejail --overlay firefox. Yet that doesn´t work.

Firefox itself produces the following message: "Your Firefox profile cannot be loaded. It may be missing or inaccessible". Yet that can´t be. Without firejail there´s no problem and even "firejail firefox" works well. The following message is taken from the terminal:

rosika@rosika-Lenovo-H520e ~> firejail --overlay firefox
Reading profile /etc/firejail/firefox.profile
Reading profile /etc/firejail/disable-mgmt.inc
Reading profile /etc/firejail/disable-secret.inc
Reading profile /etc/firejail/disable-common.inc
Reading profile /etc/firejail/disable-devel.inc
Reading profile /etc/firejail/whitelist-common.inc
Warning: --overlay and --noroot are mutually exclusive, noroot disabled
Parent pid 2362, child pid 2363
OverlayFS configured in /home/rosika/.firejail/2362 directory
Warning: cannot find home directory
***
*** Warning: cannot whitelist Downloads directory
***     Any file saved will be lost when the sandbox is closed.
***     Please create a proper Downloads directory for your application.
***
Blacklist violations are logged to syslog
Warning: failed to unmount /sys

parent is shutting down, bye.

As far as I know --overlay has been working as of kernel version 3.18. As I have 4.4.0-45-generic x86_64 there shouldn´t be any problems. Can anyone help me? Thanks a lot in advance. Rosika

P.S.: System: Linux/Lubuntu 16.04 LTS (64 bit)

6
  • I don't know if you've solved your problem, but are you on WiFi? In that case, look at github.com/netblue30/firejail/issues/151#issuecomment-159978829
    – DK Bose
    May 31, 2017 at 11:07
  • Hi DK Bose. Tnx for your reply. No, I haven´t solved my problem. I looked up the page you provided the link for. I read it very carefully and tried all of the steps described there. Yet nothing worked. I am on WiFi but I think the problem lies elsewhere. The "Warning: cannot find home directory" has to be the clue, I guess. Greetings. Rosika
    – Rosika
    Jun 1, 2017 at 14:40
  • Is your system encrypted?
    – DK Bose
    Jun 1, 2017 at 15:01
  • Hi. No, my system isn´t encrypted. It´s all a bit of a mystery to me.
    – Rosika
    Jun 3, 2017 at 13:04
  • Why don't you sign up at ubuntuforums.org? There maybe someone there who could help!
    – DK Bose
    Jun 3, 2017 at 13:12

1 Answer 1

0

When you start "firejail --overlay firefox", make sure you are not already running Firefox. See here: https://firejail.wordpress.com/support/frequently-asked-questions/#firefox

1
  • Hi nepotu. Tnx for the answer. Alas my problem lies elsewhere. When trying to use the overlay-function firefox isn´t running. Besides the problem occurs also with thunderbird, midori, rhythmbox. Yet, as a matter of fact, gedit, leafpad and nano co-operate with "--overlay". Greetings. Rosika
    – Rosika
    Nov 6, 2016 at 11:33

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .