0

I've set up ubuntu server (16.04TLS) as Access Point with hostapd and dnsmasq. For internet connection I use my built-in wifi network card (RTLINK) and for Access Point - wifi-usb adapter. Without Wifi-Usb being plugged in there is stable internet connection (I can surf internet with curl). After plugging USb-Stick (Edimax EW-7811Un) in, I can connect my devices to it (it broadcasts access point), but then there is no more any internet connection.

What can be a problem?

Gateway is 192.168.2.1

rc.local

iptables -t nat -A POSTROUTING -s 192.168.2.0/24 ! -d 192.168.2.0/24 -j MASQUERADE 

/etc/network/interfaces

    auto lo
iface lo inet loopback
auto wlx74da382e3878
iface wlx74da382e3878 inet static
hostapd /etc/hostapd/hostapd.conf
address 192.168.2.1
netmask 255.255.255.0

auto wlo1
allow-hotplug wlo1
iface wlo1 inet dhcp 
...wpa-settings 

$ifconfig (wlo1 used for connection to ADSL-Router for Internet connection)

 lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:190 errors:0 dropped:0 overruns:0 frame:0
          TX packets:190 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1
          RX bytes:15885 (15.8 KB)  TX bytes:15885 (15.8 KB)

wlo1      Link encap:Ethernet  HWaddr bc:85:56:47:69:37
          inet addr:192.168.2.103  Bcast:192.168.2.255  Mask:255.255.255.0
          inet6 addr: fe80::be85:56ff:fe47:6937/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:6935 errors:0 dropped:0 overruns:0 frame:0
          TX packets:600 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:2412406 (2.4 MB)  TX bytes:78228 (78.2 KB)

wlx74da382e3878 Link encap:Ethernet  HWaddr 74:da:38:2e:38:78
          inet addr:192.168.2.1  Bcast:192.168.2.255  Mask:255.255.255.0
          inet6 addr: fe80::76da:38ff:fe2e:3878/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:8 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:792 (792.0 B)

iwconfig ( wlx74da382e3878 (usb-wifi-adapter) serves as Access Point)

> wlo1      IEEE 802.11bgn  ESSID:"TP-LINK_D"
>           Mode:Managed  Frequency:2.417 GHz  Access Point: A0:F3:C1:D7:33:38
>           Bit Rate=1 Mb/s   Tx-Power=20 dBm
>           Retry short limit:7   RTS thr:off   Fragment thr:off
>           Encryption key:off
>           Power Management:off
>           Link Quality=70/70  Signal level=-39 dBm
>           Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
>           Tx excessive retries:0  Invalid misc:11   Missed beacon:0
> 
> wlx74da382e3878  IEEE 802.11bgn  Mode:Master  Tx-Power=20 dBm
>           Retry short limit:7   RTS thr:off   Fragment thr:off
>           Power Management:on

hostapd.conf

interface=wlx74da382e3878
logger_syslog=-1
logger_syslog_level=2
logger_stdout=-1
logger_stdout_level=2
ctrl_interface=/var/run/hostapd
ctrl_interface_group=0
ssid=TEST-WLAN
hw_mode=g
channel=1
beacon_int=100
dtim_period=2
max_num_sta=255
rts_threshold=2347
fragm_threshold=2346
macaddr_acl=0
auth_algs=3
ignore_broadcast_ssid=0
eapol_key_index_workaround=0
eap_server=0
own_ip_addr=127.0.0.1
rsn_pairwise=CCMP
wmm_enabled=1

$route -n

Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
0.0.0.0         192.168.2.1     0.0.0.0         UG    0      0        0 wlo1
192.168.2.0     0.0.0.0         255.255.255.0   U     0      0        0 wlo1
192.168.2.0     0.0.0.0         255.255.255.0   U     0      0        0 wlx74da382e3878
  • don't use the same iprange with same netmask on 2 dirrerent interfaces. – Ipor Sircer Oct 27 '16 at 12:06
  • sorry, where is it to configure? and how would be it properly to set up? – user3467471 Oct 27 '16 at 12:10
0

Ok, Ipor Sircer with his comment was right, I'd used somehow the same ip-range in my settings (for AP-connection and for Managed-connection). As my Router has 192.168.2.1 gateway-ip, I'd set up the same range for my Hostapd-wifi-adapter. The problem was resolved after setting up the address for hostapd on 10.0.0.1

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.