0

I set up a ARM64 qemu image with dropbear. I'm trying to ssh in from the host. I used the following command line to start up the guest.

#!/bin/bash

~/repos/qemu-2.6.0-rc3/aarch64-softmmu/qemu-system-aarch64 \
  -machine virt \
  -cpu cortex-a57 \
  -machine type=virt \
  -nographic -smp 1 \
  -m 2048 \
  -kernel ./arch/arm64/boot/Image \
  --append "console=ttyAMA0" \
  -net nic,model=virtio \
  -net user,hostfwd=tcp::10022-:22

In the bootlog I see the following

drivers/rtc/hctosys.c: unable to open rtc device (rtc0)
Freeing unused kernel memory: 7684K (ffffffc000715000 - ffffffc000e96000)
Freeing alternatives memory: 4K (ffffffc000e96000 - ffffffc000e97000)
Starting logging: OK
Initializing random number generator... random: dd urandom read with 1 bits of entropy available
done.
Starting network: OK
Starting dropbear sshd: OK

Welcome to Buildroot
buildroot login: root

Moreover I'm able to do a ssh root@localhost on the guest.

However, when I try to ssh in from the host I get the following :-

$ ssh root@localhost -p10022 -vvv
OpenSSH_7.2p2 Ubuntu-4ubuntu2.1, OpenSSL 1.0.2g  1 Mar 2016
debug1: Reading configuration data /home/mememe/.ssh/config
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: /etc/ssh/ssh_config line 19: Applying options for *
debug1: auto-mux: Trying existing master
debug1: Control socket "/tmp/ssh_mux_172.16.109.1_10022_root" does not exist
debug2: resolving "172.16.109.1" port 10022
debug2: ssh_connect_direct: needpriv 0
debug1: Connecting to 172.16.109.1 [172.16.109.1] port 10022.
debug1: Connection established.
debug1: identity file /home/mememe/.ssh/id_rsa type 1
debug1: key_load_public: No such file or directory
debug1: identity file /home/mememe/.ssh/id_rsa-cert type -1
debug1: key_load_public: No such file or directory
debug1: identity file /home/mememe/.ssh/id_dsa type -1
debug1: key_load_public: No such file or directory
debug1: identity file /home/mememe/.ssh/id_dsa-cert type -1
debug1: key_load_public: No such file or directory
debug1: identity file /home/mememe/.ssh/id_ecdsa type -1
debug1: key_load_public: No such file or directory
debug1: identity file /home/mememe/.ssh/id_ecdsa-cert type -1
debug1: key_load_public: No such file or directory
debug1: identity file /home/mememe/.ssh/id_ed25519 type -1
debug1: key_load_public: No such file or directory
debug1: identity file /home/mememe/.ssh/id_ed25519-cert type -1
debug1: Enabling compatibility mode for protocol 2.0
debug1: Local version string SSH-2.0-OpenSSH_7.2p2 Ubuntu-4ubuntu2.1

At this point I get no response. Why does this problem occur? My ssh config only has the following lines, so I guess that is not the problem.

ControlMaster auto
ControlPath /tmp/ssh_mux_%h_%p_%r

I have set the root password on the VM and would like to just be able to ssh in using the root password.

EDIT

If I wait long enough, I get the following line in the verbose output.

ssh_exchange_identification: read: Connection reset by peer
  • I don't actually see an error message in that output... – larsks Oct 27 '16 at 1:29
  • @larsks I'm not presented with a login prompt. Also after the last debug line pasted above, there is a halt, nothing happens. – user3655 Oct 27 '16 at 10:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy