1

I am having a Windows 7 laptop (500GB hard drive ) initially with 3 partitions ( C : around 100 GB and rest equally between D and E ) and one system reserved (very small around 400MB )(total 4).

Unaware of the fact that if we create 5 partitions in windows lead to change in basic disk to dynamic disk I did that and Created F by dividing D equally but I undo the operation by moving very small amount of data of D to E and merging all the drive to E.

Until this point I was having a * C(same) , E(around 300 GB) and F (around 100 GB (totally empty))* but not as basic one but as a dynamic disk.

Now I tried to install ubuntu onto the F drive but Ubuntu didn't find my partitions there. It showed me only 2 partitions: one was system reserved for Windows and the other of ~480 GB all of partitions as one (all because of dynamic disk). In this confused state I choose the option of lvm and clicked ok (as shown in figure). It showed me the option to write the changes or not. I clicked on Go Back and powered off the pc, But when I turned it back on I saw that Windows would not boot up and by checking the hard disk status from Ubuntu booted pen drive and seeing it as gparted image

My laptop hard drive is currently having one volume group ubuntu-vg consisting of 2 logical volume root and swap_1. I am unable to mount the root partition due to filesystem error. I have tried using logical volume manager which shows fs as none. Is there any way to recover the data from root lv?

  sudo fsck /dev/ubuntu-vg/root
  fsck from util-linux 2.27.1
  e2fsck 1.42.13 (17-May-2015)
  ext2fs_open2: Bad magic number in super-block
  fsck.ext2: Superblock invalid, trying backup blocks...
  fsck.ext2: Bad magic number in super-block while trying to open /dev/mapper/ubuntu--vg-root

  The superblock could not be read or does not describe a valid ext2/ext3/ext4
  filesystem.  If the device is valid and it really contains an ext2/ext3/ext4
  filesystem (and not swap or ufs or something else), then the superblock
  is corrupt, and you might try running e2fsck with an alternate superblock:
     e2fsck -b 8193 <device>
      or
     e2fsck -b 32768 <device>
  • It might have occurred that while Ubuntu created lvm2 it wipes the whole memory , please ans me if it has occurred.
  • as far as i understood volume group and logical volume is just an abstraction . there can be a chance that data still resides in physical disk but i am not able to see it .
  • while trying to mount the logical volume it shows me fs error .
  • running ls cmd shows me output

lrwxrwxrwx 1 root root 7 Oct 26 18:54 /dev/ubuntu-vg/root -> ../dm-0

  • what will if i run lvremove cmd to delete the logical view and then I be able to access physical volumes or they it will format the data.

output of ls -lL /dev/ubuntu-vg/root

brw-rw---- 1 root disk 252, 0 Oct 26 19:35 /dev/ubuntu-vg/root
  • yes , not working – user197076 Oct 26 '16 at 7:28
  • Could you please edit your question and add the output of fsck? – rudimeier Oct 26 '16 at 7:30
  • please have a look – user197076 Oct 26 '16 at 7:40
  • 1
    So I assume you have already tried what the output suggests: e2fsck -f -b 32768 /dev/sdb1!? Do you still remember what file system was it? – rudimeier Oct 26 '16 at 7:44
  • 1
    you got it while i was just typing the comment , i will edit it too – user197076 Oct 26 '16 at 20:03
0

You can remove the LVM signature with pvremove /dev/sda5. I would strongly recommend you read the man page before running this command.

The EaseUS Data Recovery Wizard claims to recover data from lost partitions on a damaged Dynamic Disk. You will need a spare disk to which the data can be written.

IMO, you may have lost your entire disk, so I would prepare to recover what data you can, and expect to have to reinstall from scratch. Unfortunately.

  • The question not at all off-topic. there was no problem in drive even when i made it dynamic . it actually started when ubuntu created lvm on to it. until and unless ubuntu don't remove this layer of abstraction any of the windwos software can't do anything at least like EaseUS Data Recovery Wizard. – user197076 Oct 26 '16 at 20:24
  • @user197076 I have added some additional information for you that may be useful – roaima Oct 31 '16 at 12:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.