0

There's two main problems. One is with underlines. Underlines don't consistently appear, and when switching windows they may spontaneously appear or disappear. Furthermore, when clearing the screen, underlines don't always go away with the text that was underlined; sometimes the underline remains without any text there, so I get seemingly-random horizontal lines on the terminal.

The other issue is with Unicode characters. Unicode characters that aren't in the font I use (PxPlus IBM VGA8, from here) show up cut off at the bottom of the line as the height is adjusted. Even worse, the height isn't reset, so subsequent characters on the same line appear cut off as well, and don't line up with the beginning of the line.

I've noticed that turning off bi-directional text rendering in Konsole has an effect on this, but it just replaces it with different incorrect behavior: underlines don't show up at all, and Unicode characters (along with the following non-Unicode text) are shifted up instead of down.

Here's a sample of the incorrect behavior as seen in Konsole:

Konsole (incorrect display)

And for comparison, here's gnome-terminal with the same font settings, which displays correctly:

gnome-terminal (correct display)

Does anyone know what causes this issue, and how I can fix it?

  • Looks like bugs that are probably not fixed in the source yet. Please make sure that for each of the issues a bug is filed on bugs.kde.org, if not yet then please file new ones, thanks! :) – egmont Oct 25 '16 at 22:26
  • 2
    @egmont: Done. See 371687 and 371688. – flarn2006 Oct 26 '16 at 0:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.