0

This used to work. My icewm menu has an item for running konsole. In .icewm/menu the line is:

prog "xterm" xterm  konsole 

Sometime, a month or so ago, without any changes to my .icewm/ files or /etc or anywhere, it stopped. Bringing up the menu and clicking 'xterm' (a misnomer, but whatever) nothing at all happens. Previously, a Konsole window with bash prompt would appear.

I can still get konsole to run straight from any command line in another xterm, rxvt, konsole, or gnome-terminal. There are no error messages or anything suspicious. I'm running on Arch Linux, updated just a few months ago, well before this mysterious loss of function.

Perhaps related, in Thunar, "open xterm here" doesn't do anything. It used to work, and as far as I recall, stopped working at the same time.

I tried using pacman to remove and reinstall konsole, and thunar, but no change.

Note that I'm not using the KDE desktop, but do use kwrite, konsole, ksnapshot and a few other KDE-based apps.

0

According to the documentation that should work. Its FAQ doesn't mention a way to trace its actions, but making a script to call from the menu which shows the environment variables might give some clues.

prog "traces" xterm  /tmp/mytraces

where /tmp/mytraces is your script, containing something like

#!/bin/sh
output=/tmp/mytraces.log
date >>$output
echo "SET:" >>$output
set >>$output
echo "ENV:" >>$output
env >>$output

I'd look at the PATH variable for instance, but generally look at the environment to see that it is consistent with what I see in a normal shell. Bear in mind that the window manager may be executed with fewer variables (and different) from your shell.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.