0

I was running Kali Linux 2.0 Sansa. I did the Kali Linux apt-get update && apt-get upgrade

To upgrade to Kali 2.0 rolling edition now I cannot log in The user name and password still work because if I do Ctrl+alt+f3. They work on the command line.

But in GUI it just loop over and over, keeps on asking for user name and password.

1

2 Answers 2

1

The previous answer by @JdeHaan worked for me. You can even use the solution without creating new /home/you directory (the first two steps).

cp -r /etc/skel /home/you ; chown -R you:you /home/you
4
  • I'm not sure this is an answer. It feels more like a comment on another question
    – roaima
    May 3 at 17:03
  • The disadvantage of this approach is that you lose any configuration you had that’s overwritten by files in /etc/skel. Creating a separate home avoids that — you can compare the configurations after checking that a basic setup works. May 3 at 17:51
  • @StephenKitt you don't necessarily lose the configuration because this isn't a replace it's an overwrite of the selection of files in /etc/skel. Typically nothing in ~/.config is likely to be reset
    – roaima
    May 3 at 23:01
  • @roaima yes, that’s why I wrote “that’s overwritten by files in /etc/skel”. In fact, given that all the DE configuration will be left as-is, this is unlikely to help much in the scenario given in the question. May 4 at 4:06
1

One thing you can try is rule out the useraccount settings as a cause. Since those are generally stored in your home directory (/home/you), the fastest way would be to login on another screen, make yourself root, rename your original home directory to another name (mv /home/you /home/you.old) and recreate your home directory (mkdir /home/you ; cp -r /etc/skel /home/you ; chown -R you:you /home/you). Another possibility would be to create another new user and try that.

1
  • I tried creating a user....userad -m user1 ....usermod -a -G sudo user1...then Oct 25, 2016 at 22:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.