1

Two RHEL 6.8 servers. One test, one production. In theory derived from the same build channel in Satellite.

I spotted an issue on the production server when trying to add an ACL to a directory on an LV on a secondary volume group /data.
The ACL works perfectly on test server however when applying to the production server I get the following...

setfacl: /data/dir1: Operation not supported

So acl option is probably not set for this mount point.

In /etc/fstab both are using defaults...

/dev/mapper/vg02-data   /data                   ext4    defaults        1 2

The output of mount -l is identical but the output of tune2fs differs...

testserver:root:~> mount -l | grep data
/dev/mapper/vg02-data on /data type ext4 (rw)

prodserver:root:~> mount -l | grep data
/dev/mapper/vg02-data on /data type ext4 (rw)

testserver:root:~> tune2fs -l /dev/mapper/vg02-data | grep options
Default mount options:    user_xattr acl

prodserver:root:~> tune2fs -l /dev/mapper/vg02-data | grep options
Default mount options:    (none)

Kernel version of both is 2.6.32-642.6.1.el6.x86_64

I was under the impression that ACLs are enabled for extX file systems by default on RHEL and derivatives.
Where are these default options set?

2

Try this:

:~# mount -o remount,acl /data

or

:~# for i in /dev/mapper/vg02-data ; do
umount $i
tune2fs -o acl $i
mount $i
done

and after that:

:~# tune2fs -l /dev/mapper/vg02-data | grep options

You can also add rigidly to the /etc/fstab:

/dev/mapper/vg02-data   /data    ext4    acl,defaults    1 2
  • Thanks. I am aware of how to add the acl option. I'm just curious as to why one volume on one server has it in its defaults but another volume on another server doesn't. I would expect there to be OS-level consistency with this setting. – batfastad Oct 24 '16 at 9:51
  • 4
    Check cat /etc/mke2fs.conf | grep default [defaults] default_mntopts = acl,user_xattr – user192526 Oct 25 '16 at 10:07
  • @Bahamut Great suggestion! Though files are identical on both servers and do not contain a default_mntopts section. – batfastad Oct 27 '16 at 9:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.