0

I'm working on kernel 2.6.37, i have made some loadable module instead of static to optimize kernel,

My task is to load some module after running a application which i'm doing successfully,

In any embedded system, at initialization of system a script modpobe the modules from designated file such as etc/modules. so i have removed module name to not load at filesystem initialization rather need to be loaded after application starts. more like runlevel priority changed from 35 to 99.

Now my wifi kernel module takes 1-2sec to load so i tried to remove wifi module name and it's dependencies but wifi modules is loading at file system initialization. upon checking the rcS script, udev script is running a udevadm trigger which is loading the module rather it should be done by modprobe.

/sbin/udevadm trigger --subsystem-nomatch=tty --subsystem-nomatch=mem --subsystem-nomatch=vc --subsystem-nomatch=vtconsole --subsystem-nomatch=misc --subsystem-nomatch=dcon --subsystem-nomatch=pci_bus --subsystem-nomatch=graphics --subsystem-nomatch=backlight --subsystem-nomatch=video4linux --subsystem-nomatch=platform

can anyone suggest how to avoid wifi module loading ?

  • 1
    welcome to U&L, your question is a bit unclear, are you trying to laod a user defined module, and wondering how to do it before or after wifi ? are you trying to disable wifi all together ? – Archemar Oct 24 '16 at 6:36
  • this is a embedded project, i have builded wifi module w.r.t kernel by following these link processors.wiki.ti.com/index.php/…. i want to delay wifi loading but unable to do it. – GBiradar Oct 24 '16 at 6:57
0

these is not perfect answer for my question but more of a workaround,

i made some module blacklist[it will stop autoload at file system initialization] and modprobe after my application runs.

cat /etc/modprobe.d/blacklist.conf

#blacklist those modules who need to stop from autoloading

blacklist wl18xx

if anyone has better answer please do share.

thanks & regards, GBiradar

  • this is exactly how the docs tell you to prevent a specific module autoloading. hence why it doesn't prevent manual modprobe of the module. if you want a different answer you're going to have to work out what your real question is :p – sourcejedi Oct 24 '16 at 14:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.