7

I have enabled the mode prompt indicator in my ~/.inputrc with set show-mode-in-prompt on. There is a delay of about half a second in the indicator when switching to normal mode after pressing ESC but no delay in the indicator when entering insert mode. I am aware of a similar issue experienced inside of Vim and when using Tmux or Screen with Vi mode turned on (see e.g. ESC key causes a small delay in terminal due to its Alt+ behavior). There are solutions for each of those delays but I haven't found a way to fix the delay in my specific case (Bash + urxvt). Any ideas?

7

That sounds like keyseq-timeout, which is 500 (milliseconds). You could decrease it, e.g., to 50 (milliseconds). Setting it to zero would be a bad idea (see for example Re: How does one disable completion when nothing but tabs or spaces is on the line?).

Not a duplicate, but one of the answers in How do I switch to vi editing mode in readline? uses the feature:

# Enable Readline not waiting for additional input when a key is pressed.
# Needed for the mappings below.
set keyseq-timeout 0
  • Exactly what I needed. – ramblenode Oct 25 '16 at 1:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.