1

friend of mine got an asus x555UJ notebook with hybrid graphics (corei5 and geforce920m). we put debian jessie on it with gnome and bumblebee (https://www.unixmen.com/how-to-make-nvidia-optimus-technology-work-properly-on-debian/). and we have problems.

problem 1: after fresh install there is only 1024x768, and this not changed even after bumblebee install.

problem 2: bumlebee seems to work but when it changes to the nvidia card it seems to crashes the libGL.so.1 (trying the the glxgears). we installed the bumblebee and nvidia from the jessie-backport as the nvidia-driver from the backport is needed for the 920m support. here is the inxi output:

> @debian:~$ inxi -F
System:    Host: debian Kernel: 3.16.0-4-amd64 x86_64 (64 bit) Desktop: Gnome 3.14.4 
           Distro: Debian GNU/Linux 8 
Machine:   Mobo: ASUSTeK model: X555UJ v: 1.0 Bios: American Megatrends v: X555UJ.207 date: 03/14/2016
CPU:       Dual core Intel Core i5-6200U (-HT-MCP-) cache: 3072 KB 
           Clock Speeds: 1: 700 MHz 2: 400 MHz 3: 400 MHz 4: 2100 MHz
Graphics:  Card-1: Intel Device 1916
           Card-2: NVIDIA Device 1299
           Display Server: X.Org 1.16.4 drivers: fbdev,intel (unloaded: vesa) Resolution: 1024x768@0.00hz
           GLX Renderer: Gallium 0.4 on llvmpipe (LLVM 3.8, 256 bits) GLX Version: 3.0 Mesa 12.0.3
Audio:     Card Intel Device 9d70 driver: snd_hda_intel Sound: ALSA v: k3.16.0-4-amd64
Network:   Card-1: Realtek RTL8723BE PCIe Wireless Network Adapter driver: rtl8723be
           IF: wlan0 state: up mac: c8:ff:28:e0:ad:89
           Card-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller driver: r8169
           IF: eth0 state: down mac: d0:17:c2:26:ee:c2
Drives:    HDD Total Size: 1000.2GB (1.0% used) ID-1: /dev/sda model: ST1000LM024_HN size: 1000.2GB
Partition: ID-1: / size: 913G used: 5.2G (1%) fs: ext4 dev: /dev/sda2 
           ID-2: swap-1 size: 4.18GB used: 0.00GB (0%) fs: swap dev: /dev/sda3 
Sensors:   System Temperatures: cpu: 32.0C mobo: N/A 
           Fan Speeds (in rpm): cpu: N/A 
Info:      Processes: 156 Uptime: 21 min Memory: 873.1/3639.9MB Client: Shell (bash) inxi: 2.1.28 
viki@debian:~$ 

and this is the dmesg output after the primusrun glxgears fails:

[ 1122.512967] bbswitch: enabling discrete graphics
[ 1122.758231] [drm] Initialized nvidia-drm 0.0.0 20150116 for 0000:01:00.0 on minor 0
[ 1122.758236] NVRM: loading NVIDIA UNIX x86_64 Kernel Module  352.79  Wed Jan 13 16:17:53 PST 2016
[ 1122.778862] vgaarb: this pci device is not a vga device
[ 1122.779347] nvidia 0000:01:00.0: irq 145 for MSI/MSI-X
[ 1122.781784] ACPI Warning: \_SB_.PCI0.RP01.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20140424/nsarguments-95)
[ 1122.781838] ACPI Warning: \_SB_.PCI0.RP01.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20140424/nsarguments-95)
[ 1122.781866] ACPI Warning: \_SB_.PCI0.RP01.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20140424/nsarguments-95)
[ 1122.781892] ACPI Warning: \_SB_.PCI0.RP01.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20140424/nsarguments-95)
[ 1122.781917] ACPI Warning: \_SB_.PCI0.RP01.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20140424/nsarguments-95)
[ 1122.781942] ACPI Warning: \_SB_.PCI0.RP01.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20140424/nsarguments-95)
[ 1122.781983] ACPI Warning: \_SB_.PCI0.RP01.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20140424/nsarguments-95)
[ 1122.782009] ACPI Warning: \_SB_.PCI0.RP01.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20140424/nsarguments-95)
[ 1125.768715] ACPI Warning: \_SB_.PCI0.RP01.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20140424/nsarguments-95)
[ 1126.023441] vgaarb: this pci device is not a vga device
[ 1126.514738] glxgears[3925]: segfault at 0 ip 00007f4b4e1d7794 sp 00007ffcac944bf0 error 4 in libGL.so.1[7f4b4e1b2000+41000]
[ 1126.582072] ACPI Warning: \_SB_.PCI0.RP01.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20140424/nsarguments-95)
[ 1126.586861] [drm] Module unloaded
[ 1126.588709] bbswitch: disabling discrete graphics
[ 1126.588723] ACPI Warning: \_SB_.PCI0.RP01.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20140424/nsarguments-95)
[ 1126.603612] pci 0000:01:00.0: Refused to change power state, currently in D0

lspci

01:00.0 3D controller: NVIDIA Corporation Device 1299 (rev ff)

and chunk from the xorg.conf.nvidia:

viki@debian:~$ cat /etc/bumblebee/xorg.conf.nvidia
Section "ServerLayout"
    Identifier  "Layout0"
    Option      "AutoAddDevices" "false"
    Option      "AutoAddGPU" "false"
EndSection

Section "Device"
    Identifier  "DiscreteNvidia"
    Driver      "nvidia"
    VendorName  "NVIDIA Corporation"

#   If the X server does not automatically detect your VGA device,
#   you can manually set it here.
#   To get the BusID prop, run `lspci | egrep 'VGA|3D'` and input the data
#   as you see in the commented example.
#   This Setting may be needed in some platforms with more than one
#   nvidia card, which may confuse the proprietary driver (e.g.,
#   trying to take ownership of the wrong device). Also needed on Ubuntu 13.04.
BusID "PCI:01:00:0"

any help would be appreciated!

thanks!

this was the primary source for the solution: http://forums.debian.net/viewtopic.php?f=17&t=130255&start=30

  • it seems that problem 1 above has been solved by just upgrading kernel to the jessie-backport version. and this has been solved the screen resolution issue and on top of that it has been made the touchpad working. and also the audio jack is detected, so when attaching the headphones the system changes automatically the audio outpot from speak to headphones:) This was the source of wisdom : forums.bunsenlabs.org/viewtopic.php?id=1257 – g6b0r Oct 26 '16 at 6:25
0

Have you tried bumblebee with nouveau (also are you sure about the backport driver for 920m - I'm sure that my 820m works with current- I'm on stretch- drivers), also I get weird results when using primusrun, better try optirun, but I don't think that will solve the issue.

Because IMHO : the issue is this one:

You haven't configured /etc/bumblebee/xorg.conf.nvidia ( or nouveau) with the correct PCI BusID.

just do a lspci |grep -i 3D to get the correct PCI BusID( your card is not on 01:00:00)

if it doesn't fix it. come back here ASAP.

  • I made edit of the post above. I think this is ok in the config but please check above in the post. – g6b0r Oct 23 '16 at 17:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.