2

I am running Debian 8 on my desktop, Xfce - If that matters?

My issue; New Logitech wireless keyboard, I hit the Mute button,the sound goes off, Almost automatically hit it again but the music doesn't come back on.

Almost like I hit the key to hard and it killed the sound for good Lol.

  1. I have rebooted. Still no good.
  2. I plugged old keyboard in and tried muting un-muting.
  3. Have tried root & user accounts. No sound.
  4. Have tried another set of head phones.
  5. Have tried different media players and files.
  6. Have looked at my devices to make sure it still exists in lspci. It does.
  7. The mute/un-mute graphic works/changes and I can raise and lower the volume bar graphically also.
  8. Have tried the alsamixer from terminal, sound devices listed but no good either.

Any ideas or help would be lovely, I'm looking at a reinstall otherwise right ?

Cheers

  • I even booted a Live CD Linux Distro and the audio works fine on same computer ! – Yours_Loopy Oct 23 '16 at 14:23
  • Have you checked in alsamixer if any controls are muted? ("MM" instead of "OO" at bottom). Which program processes the mute key in the first place? BIOS? Some part of the Xfce default configuration? Can you see the key in xev? – dirkt Oct 23 '16 at 16:32
3

That happened to me too a while ago. Try to install pulse audio volume control:

sudo apt-get install pavucontrol

You can start it with:

pavucontrol

from a terminal.

Once up an running, unmute your device(s). This solved my issue, hopefully it will work for you too!

  • Thanks for the reply - I did try this although it did not fix the problem unfortunately. – Yours_Loopy Oct 23 '16 at 14:24
  • Pulse audio even is receiving the sound input, I can see the levels moving although nothing is being output. – Yours_Loopy Oct 23 '16 at 14:25
1

I have the same issue, but what usually works for me is:

sudo alsa force-reload
sudo killall pulseaudio

Then touch a volume key to unmute it (as it's usually muted afterwards) and try restarting programs playing media -- it should work.

Note that you will have to do this on every reboot. Perhaps you could add it to cron?

If this doesn't fix it, I can't possibly think of another solution and reinstalling might be the only option.

I don't know why this happens. I expect it is quite an old bug that has just stuck around on my Ubuntu desktop, across upgrades...

  • 1
    Thanks man, I think this was the fix. Did you mean alsamixer force-reload ? Thanks again. – Yours_Loopy Oct 23 '16 at 17:22
  • @Yours_Loopy No, alsa like /sbin/alsa from package alsa-base (main) – cat Oct 23 '16 at 17:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.