170

I'm a Windows guy, dual booted recently, and now I'm using Linux Mint 12

When a Windows desktop freezes I refresh, or if I am using a program I use alt + F4 to exit the program or I can use ctrl + alt + delete and this command will allow me to fix the Windows desktop by seeing what program is not responding and so on.

Mint freezes fewer times than my XP, but when it does, I don't know what to do, I just shut down the pc and restart it.

So is there a command to fix Linux when it freezes?

0

9 Answers 9

136

If all else fails, you Raise The Elephant.  Essentially, there are special Magic SysRq key sequences (Alt+SysRq+?) that the Linux kernel handles specially.

If your Linux box freezes and simply won't yield to any other key-commands, you should definitely try one particular key sequence before a hard reboot.

The key sequence is popularly remembered with the mnemonic:

Raising Elephants Is So Utterly Boring

  • Alt+SysRq+R switch keyboard to 'raw' mode
  • Alt+SysRq+E send SIGTERM (termination) signal to all processes except mother init
  • Alt+SysRq+I send SIGKILL signal to all processes, a little more aggressive
  • Alt+SysRq+S sync all filesystems to prevent data loss
  • Alt+SysRq+U remount filesystems as read-only
  • Alt+SysRq+B forcefully reboot
11
  • 13
    This does, of course, require that Magic SysRq support is compiled in.
    – Alexios
    Mar 14, 2012 at 13:58
  • 5
    Problem: some modern keyboards do not have a SysRq key... (the one I'm typing from right now doesn't, for instance - although it does have "print screen", "scroll lock" and "pause/break")
    – Dalker
    Feb 26, 2014 at 10:28
  • 20
    @Dalker I just had success with using the Print Screen key instead of SysRq
    – user60561
    Sep 23, 2014 at 3:05
  • 9
    How much time should be allowed for between running each of these commands? Nov 18, 2014 at 21:19
  • 41
    Reboot Even If System Utterly Broken
    – angrydust
    Feb 28, 2016 at 21:49
128

You can try Ctrl+Alt+* to kill the front process (Screen locking programs on Xorg 1.11) or Ctrl+Alt+F1 to open a terminal, launch a command like ps, top, or htop to see running processes and launch kill on not responding process.

Note: if not installed, install htop with sudo apt-get install htop.

Also, once done in your Ctrl+Alt+F1 virtual console, return to the desktop with Ctrl+Alt+F7.

10
  • 7
    For a windows guy and a beginner in Linux, I would recommend installing htop instead of top as it is easier to operate.
    – Palec
    Sep 2, 2014 at 14:01
  • 2
    Wasn't the kill foreground process under pointer key combination Ctrl + Alt + Esc, or did that change? (And why do my key buttons not show correct formatting?)
    – Franki
    Nov 27, 2014 at 5:44
  • 3
    Which asterisk should in use for Ctrl+Alt+*? The one on the numeric keypad or in the alpha block? In the latter case, what would I press on non-US keyboards?
    – user149408
    Jan 29, 2015 at 10:11
  • 1
    Only the asterisk on numeric keypad should work, @user149408. The linked thread in oss-sec mailing list suggest that.
    – Palec
    Jan 30, 2017 at 16:04
  • 1
    My console opens with Ctrl+Alt+F3 not F1 . I'm using fedora workstation 28 Jul 5, 2018 at 20:41
42

In most distros pressing Ctrl+Alt+Backspace kills the X11 (graphic) interface and restarts it. Unfortunately some recent, supposedly "user friendly" distros deactivated this very useful shortcut for some unfathomable reason. I don't know if Mint is so "user friendly" but you have nothing to lose trying it :)

6
  • 6
    Make sure this is enabled in Mint by searching for 'Startup Applications' in the menu, and then making sure 'Ctrl Alt Backspace' is checked.
    – Jeshurun
    Apr 12, 2013 at 10:58
  • 1
    AFAIRK,the newer fancy xorg evdev input drivers disable the 'zapping' by default. However, there is a way to reenable them on startup in /etc/xorg.conf or /etc/xorg.conf.d/XX-somefile or set it in a per-user xorg startup script (maybe put setxkbmap -option "terminate:ctrl_alt_bksp" into ~/.xinitrc) by adding the line Option "XKbOptions" "terminate:ctrl_alt_bksp" into a corresponding Section "InputClass", or by setting another switch in your OS that relays to do that.
    – Franki
    Nov 27, 2014 at 5:57
  • 1
    It is still on by default in OpenSUSE Tumbleweed.
    – Geoffrey
    Dec 3, 2016 at 10:52
  • 1
    In Fedora [install,] open gnome-tweaks and check 'key sequence to kill Xserver' in the mouse/keyboard section Jul 15, 2019 at 14:35
  • 1
    Run dpkg-reconfigure keyboard-configuration to enable it (in the last step) in Ubuntu.
    – Zheng Qu
    Jul 22, 2021 at 8:48
13

Besides what was already mentioned, I also use those tricks:

  • If by any chance the unresponsive program was started in a terminal, I would try a Ctrl+D or Ctrl+C. If nothing happens I'd try a Ctrl+Z followed by a ruthless kill.

  • If I knew the responsible program, I would open a terminal and use killall. (E.g., killall firefox)

  • Alternatively, under Gnome, I would launch run command and invoke xkill, which allows you to kill a program by simply clicking on a window it owns.

  • Finally, just in case my keyboard melts, I have a System Monitor applet (also under Gnome) which will pop up the gnome-system-monitor when clicked. From there, I can kill any process I own using only my mouse.

10

Adding one more possible solution to the mix, and (apart from the accepted answer) one of the least destructive of the answers so far.

If you cannot:

  • Use keyboard/mouse to A) Run the Ctrl+Alt+* option above, B) Navigate to a utility that can be used to terminate the offending program, C) Launch a terminal to initiate a pkill <process name> (or similar, as detailed above)

-OR-

  • Switch to another virtual console (Ctrl+Alt+any one ofF1-6), to initiate a pkill <process name> (or similar, as detailed above)

... then assuming MagicSysRq support is compiled into the kernel (From http://en.wikipedia.org/wiki/Magic_keys), on a QWERTY keyboard (alternatives for the below f are provided in the aforementioned article), one can try:

Alt+SysRq(Note caveats on http://en.wikipedia.org/wiki/Magic_keys#Commands)+f to
"Call oom_kill, which kills a process to alleviate an O ut  O f  M emory condition", which (at least for me) often kills the program that is causing the issue, as it is the largest RAM consuming process running at the time.

8

On laptops you might need to press CtrlFnF1 to open terminal, what I do is type reboot now to restart from terminal.

To go back to the GUI from terminal on my laptop (HP G56) I have to CtrlFnF8 (apparently it could also be CtrlFnF7) and you should be back to graphical interface.

Also check http://community.linuxmint.com/tutorial/view/244

Stopping & Starting

  • shutdown -h now – Shutdown the system now and do not reboot
  • halt – Stop all processes - same as above
  • shutdown -r 5 – Shutdown the system in 5 minutes and reboot
  • shutdown -r now – Shutdown the system now and reboot
  • reboot – Stop all processes and then reboot - same as above
  • startx – Start the X system
6

Another suggestion if you are using Gnome3 (I think the default Mint installation uses something similar), you can use CTRL+F2 then press R and hit return. I use this often and it works. It basically restarts the GUI. Even if you don't see anything on the screen (e.g., it is frozen) you should do that and it will restart the GUI.

4
  • ctrl f2 does not work anymore :( dunno why
    – Lynob
    Feb 16, 2012 at 20:10
  • maybe isn't works in the Mint GUI, since the default Mint GUI isn't exactly Gnome, but on Gnome 3 it works for sure.
    – Hanan N.
    Feb 16, 2012 at 20:51
  • 3
    Instead of Ctrl+F2, press Alt+F2. Then it works fine.
    – user16437
    Mar 9, 2012 at 16:43
  • 1
    This changed in GNOME3. Pressing Alt+F2 will open a run box where you can type the command r. This is restarting gnome-shell, which in GNOME 3.x has had many memory leaks which lead to it becoming slower and slower over time. Performing this restart released much of this RAM.
    – slm
    Mar 8, 2014 at 6:39
3

On my laptop when it completely freezes (unresponsive mouse or keyboard) on mint 17.3, I'm able to do control + alt + fn + f7, then control + alt + fn+ f2. This gets to the shell, then I login with my username and password. To go back to the desktop I do chvt 8 this gets me back to my current desktop. To find out the active tty's type w then chvt to the current one.

That way you can resume your work without rebooting or losing anything.

2

Not yet mentioned but might work in some cases - try CTRL+ALT+RIGHTARROW or LEFTARROW. This did switch workspaces, and doing so somehow unhitched whatever was blocking mouse and keyboard actions. I could then switch back to the first workspace, kill Chromium, which I had by then figured had crashed and was hogging all keyboard and mouse events. Now everything's back to normal, no reboot or loss of anything involved.

In my case, just minutes ago, everything was hung except the mouse moved the cursor, but the mouse did no more. The PrtScn made a popup saying I could drag a rectangle (but not) or hit ESC (works). Nothing else worked. Not even moving the cursor onto another window, when I have focus-follows-mouse, changes the window frame highlighting. But Ctrl+Alt+F3 did switch to a text term, Ctrl+Alt+F1 brought back the X windows session.

The culprit was Chromium. I was reading, switched tabs in one browser window, and upon clicking the tab everything froze but for the few things just described. Switching workspaces

Not the answer you're looking for? Browse other questions tagged or ask your own question.