0

I installed turnkey wordpress (turnkey-wordpress-14.0-jessie-amd64-disk1) on one computer and then I moved the vmdk to another computer.

Now when I boot up the VM I get the turnkey windows with all URL how to connect to it. The IP is 192.168.2.100

I can ping that IP and can ssh to that IP. If I do ifconfig on the box then can see the correct IP 192.168.2.100

When I type this IP to my web browser then I get

The connection has timed out

The server at 192.168.15.101 is taking too long to respond.

and the browser's address bar changes from 192.168.2.100 to http://192.168.15.101/index.php/en/

I might have set up something on the VM box but I cannot remember.

Would someone be able to help me to fix that?

I am using

  • Win10
  • VirtualBox 5.1.8
  • wifi adapger

One of my old WP turnkey VM works fine

UPDATE

I created brand new VM using that vmdk. I was not able to use bridged networking at first but after upgrading VirtualBox to the latest version my old VM (turnkey too) works fine. It's using the same network settings.

Now I deleted the VM that I created yesterday and then created new one from scratch. The result is the same.

I would suspect that the vmdk remembers some settings but I have no idea what and where to fix that.

Currently I am running grep -Ril "192.168.15.101" /. Running the grep in /etc didn't give me any result.

2

According to this page Wordpress stores its local IP/domain name in the database, so you'll have to update it there to prevent the URL from being rewritten to an address you don't want anymore.

Connect to your mysql database for the wordpress site and run

UPDATE wp_options SET option_value = "http://192.168.2.100" WHERE option_value = 'http://192.168.15.101';

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.