3

I'm trying to setup wake on LAN on my desktop which has Ubuntu 16.04 running.

I've tried a lot, following different manuals and troubleshooting, but with no luck.

When the computer is off or on suspend, one orange light is on the network card, occasionally slightly flickering. I need to resume or turn on computer via LAN if it is suspended or turned off respectively.

I believe I have wake on LAN enabled in the BIOS.

Some outputs that I think might be relevant,

$ sudo ethtool enp2s0 | grep Wake
    Supports Wake-on: pumbg
    Wake-on: g

$ sudo ethtool -i enp2s0 | grep bus
bus-info: 0000:02:00.0

$ cat /proc/acpi/wakeup | grep 0000:02:00.0
PXSX      S4    *enabled   pci:0000:02:00.0

$ lspci | grep Ethernet
02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 0c)

$ cat /etc/default/halt 
# Default behaviour of shutdown -h / halt. Set to "halt" or "poweroff".
HALT=poweroff
NETDOWN=no

$ sudo tcpdump -i enp2s0 '(udp and port 7) or (udp and port 9)'
tcpdump: verbose output suppressed, use -v or -vv for full protocol decode
listening on enp2s0, link-type EN10MB (Ethernet), capture size 262144 bytes
15:31:38.121365 IP <ip>.51603 > <broadcast_ip>.discard: UDP, length 102

I even tried the r8168 driver with no luck.

I'm sending WOL signal with the following command

$ wakeonlan -i <broadcast_ip> <mac_addr>

Any ideas?

  • Does the tcpdump output show that your network is allowing the packet to reach your system? – Vivek Ghaisas Oct 24 '16 at 11:35
  • I guess tcpdump shows packets that actually reached my system, that is network allowed it to reach my system. No? – nisargjhaveri Oct 24 '16 at 11:37
  • I wasn't sure what those parameters to tcpdump did, so I just wanted to confirm whether that was the intention of running that command. :) – Vivek Ghaisas Oct 24 '16 at 11:41
0

I believe I have wake on LAN enabled in the BIOS.

Make sure you have it enabled in BIOS, because it is a pre-requisite of WoL working.

Wake-on: g

Magic packet setting must be persistent. If it is not after power cycle, you might want to try setting in the following file:

/etc/netctl/profile

as follows:

ExecUpPost='/usr/bin/ethtool -s interface wol g'

Further reading on ArchWiki.

-1

Set WOL_DISABLE=N in /etc/default/tlp and NETDOWN=no in /etc/default/halt

  • 2
    Welcome to Unix & Linux Stack Exchange.  Please don’t post answers that are just configuration settings and no explanation.  Please explain what these do.  This doesn’t have to be long but it is expected. – Scott Feb 6 '17 at 20:25
  • 1
    I have NETDOWN=no set in /etc/default/halt. It is already mentioned in the question. And tlp is not in use. – nisargjhaveri Feb 7 '17 at 6:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.