12

I just got dual monitors and I want to restrict my Wacom tablet to draw on only one. Unfortunately, xsetwacom doesn't seem to recognize the DVI inputs--even though they're listed in xrandr plain as day. Any ideas?

Here's my console output:

andrewcarr@andrewcarr-desktop:~$ xrandr
Screen 0: minimum 8 x 8, current 3200 x 900, maximum 16384 x 16384
DVI-I-0 connected primary 1600x900+1600+0 (normal left inverted right x axis y axis) 443mm x 249mm
   1600x900      60.00*+
   1440x900      59.89  
   1280x1024     60.02  
   1280x720      60.00  
   1024x768      60.00  
   800x600       60.32  
   640x480       59.94  
DVI-I-1 disconnected (normal left inverted right x axis y axis)
HDMI-0 disconnected (normal left inverted right x axis y axis)
DVI-D-0 connected 1600x900+0+0 (normal left inverted right x axis y axis) 443mm x 249mm
   1600x900      60.00*+
   1440x900      59.89  
   1280x1024     60.02  
   1280x720      60.00  
   1024x768      60.00  
   800x600       60.32  
   640x480       59.94  
 andrewcarr@andrewcarr-desktop:~$ xsetwacom set "Wacom Intuos PT M Pen stylus" MapToOutput DVI-I-0
Unable to find an output 'DVI-I-0'.

2 Answers 2

21

Instead of the monitor name from xrandr, use HEAD-[head index]. For instance, use HEAD-0 for the first monitor listed, HEAD-1 for the second, etc.

e.g. xsetwacom --set "Wacom Intuos PT S 2 Pen stylus" MapToOutput HEAD-1

1
  • Thanks! I added this solution to my little sh script that allows me to select the screen for my tablet :)
    – sodimel
    Jun 4, 2023 at 18:14
3

I was curious as to why on my system I had to use HEAD-0 and HEAD-1 as well. The man xsetwacom mentions NVIDIA drivers:

enter image description here

On Arch Linux, this is my NVIDIA driver version as of today:

$ pacman -Si nvidia
Repository      : extra
Name            : nvidia
Version         : 510.60.02-17
Description     : NVIDIA drivers for linux
Architecture    : x86_64
URL             : https://www.nvidia.com/
Licenses        : custom
Groups          : None
Provides        : NVIDIA-MODULE
Depends On      : linux  nvidia-utils=510.60.02  libglvnd

xrandr:

$ xrandr --version
xrandr program version       1.5.1
Server reports RandR version 1.6

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .