1

I have a Samsung Series 7 Chronos Laptop with a Synaptics trackpad, on which I recently installed Arch Linux. My trackpad has worked fine without configuration on debian-based distros and openSuse Tumbleweed, however, on Arch, it becomes absolute (i.e. each corner of the trackpad directly corresponds to a corner of the screen, so I can't really click on things unless I keep my finger in exactly the same spot).

Things I've tried:

  • All my Synaptics drivers are updated

  • installing the f86-input-synaptics package, no options seem to show promise

Any thoughts? To be clear, the touchpad works. However, it seems to be mapped absolutely to my screen, which renders it basically useless.

1

I had the same problem. You sold not use synaptics, use libinput instead, is more modern and is compatible with wayland.

To install:

pacman -S xf86-input-libinput 

If it didn't work out-of-the-box you create the file /etc/X11/xorg.conf.d/30-touchpad.conf with the content:

Section "InputClass"
        Identifier "MyTouchpad"
        MatchIsTouchpad "on"
        Driver "libinput"
        Option "Tapping" "on"
EndSection

Obs: Remember to restart Xorg

More detail here.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.