1

What is the reason behind kernel can not get init file though this file present in target architecture?

i am working on BF548 EZKIT, And completed NOR boot Mode. But In NAND boot mode I had flash u-boot.ldr , uImage and rootfs.jffs2 file on specified mtdblocks on specific address, during boot my kernel loaded successfully, mounted rootfs successfully, and after that gives error

VFS: Mounted root (jffs2 filesystem) on device 31:9.

devtmpfs: error mounting -2

Freeing unused kernel memory: 140K (003b4000 - 003d7000)

Kernel panic - not syncing: No working init found.  Try passing init= option to kernel. See Linux Documentation/init.txt for guidance.

Also i had tried init=/sbin/init and other init options in kernel command line but none of them work.

  • How do you know it is "present"? Did you confirm that the mounting was indeed done correctly? – phk Oct 21 '16 at 13:49
  • Can you instruct me how can i confirm that? And i had checked target folder created in "/output/" directory and in "/target/sbin/" directory i confirm that there is "init" available , and also i had generate jffs2 filesystem manually using "mkfs.jffs2" but no luck and same error. – chex Oct 22 '16 at 4:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.