Once I had windows 7 on a internal HDD and wanted to install backtrack 5 on another internal HDD on the same PC. When installation completed, I rebooted and found only backtrack 5. I booted a live iso of backtrack 5 operating system and executed the following commands:

sudo apt-get install software-properties-common
sudo add-apt-repository ppa:yannubuntu/boot-repair
sudo apt-get update
sudo apt-get install -y boot-repair && boot-repair

And that solved the problem. boot-repair was installed and ran successfully and I was able to chose which operating system to launch at power up.

A few days ago, I decided to upgrade to the successor kali Linux, so I downloaded the iso, burned it to a disc and installed it to the HDD that was hosting backtrack 5. Similarly, when I rebooted I was only presented with kali without windows 7. I tried to follow the method as earlier to dual boot, but I ran into an error message:

Unable to find package boot-repair. (I don't remember it literally)

I have searched a lot, and found a boot-repair iso, which is lubuntu with boot-repair, gparted and other programs. I burned it to disk, and launched it, and the boot-repair was up. It ran and displayed that it has repaired and the pc is ready after reboot.

When I rebooted, I was presented with black screen with error message:

No operating system found.

Please help.

  • 1
    "I don't remember much" is as helpful as "It didn't work" - i.e. not helpful at all. If I understand you correctly, you didn't actually use the OS for too long; therefore the easiest way is to install your Kali once again and then search in the Internet on how to find Windows 7. Oct 21, 2016 at 12:02

5 Answers 5


Backtrack now called Kali is made from Ubuntu which is made from Debian... any way most Linux on x86 will use the GRUB boot loader.
Following the GRUB repair instructions from Ubuntu is a good start.

  • The first thing to do is know what should happen (Bios->GRUB->OS)
  • The second thing is to know what's working (Is the Bios loading GRUB?) if it's not you need to re-install grub, if it is you need to edit the GRUB config so it knows what OSs you have and how to load them. You can install and configure GRUB from most any Linux live ISO.

Similarly, when I rebooted I was only presented with kali without windows 7

have you attempted to simply boot kali, then run;

sudo update-grub2

You don't need a live iso to fix boot, as you can use the valid linux install to do this, update-grub2 will detect any windows partitions and add them to the grub list.

If you still don't see windows from the boot menu, you can run;

sudo grub-install /dev/sd?

Only if you are unable to boot any partition, even with grub-rescue do you need a live cd to fix boot.


You can use the old Backtrack 5 iso and perform the same commands as you had used earlier. This is just a solutions for your problem so that you get your computer back to usable condition but not an answer to why.


Boot the Kali Live CD in live mode. Open a terminal and run fdisk -lu


Disk /dev/sda: 931.5 GiB, 1000204886016 bytes, 1953525168 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: dos
Disk identifier: 0xd9fa2484

Device     Boot      Start        End   Sectors   Size Id Type
/dev/sda1             2048     206847    204800   100M  7 HPFS/NTFS/exFAT
/dev/sda2           206848  204802047 204595200  97.6G  7 HPFS/NTFS/exFAT
/dev/sda3        204802048 1023999999 819197952 390.6G  7 HPFS/NTFS/exFAT
/dev/sda4       1024004094 1953523711 929519618 443.2G  5 Extended
/dev/sda5       1024004096 1663361023 639356928 304.9G  7 HPFS/NTFS/exFAT
/dev/sda6       1663363072 1711697919  48334848    23G 83 Linux
/dev/sda7       1711699968 1774604287  62904320    30G 83 Linux
/dev/sda8  *    1774616576 1932972031 158355456  75.5G 83 Linux
  /dev/sda9       1932986368 1953523711  20537344   9.8G 82 Linux swap / Solaris

   Partition 4 does not start on physical sector boundary.

Note the last column (type). The drive you have installed Linux will show up as Linux. In my case, there are 3. Note the number dev/sdaX. Replace X with your partition number.


mount /dev/sdaX /mnt
grub-install --root-directory=/mnt /dev/sda

If you get command not found error, try installing GRUB using apt

After GRUB is successfully installed, run

mount -o bind /dev /mnt/dev
mount -o bind /proc /mnt/proc
mount -o bind /sys /mnt/sys
chroot /mnt

If you get a command not found error in update-grub run grub-mkconfig -o /boot/grub/grub.cfg

After it says done type exit and get out of the chroot. Then reboot.

These are the steps I used in a script to install my Linux From Scratch from Live CD. Try and see if it works.


Try this Solution chroot without installing the Kernel-image and Kernel-headers.

You must log in to answer this question.