0

In centos7, I don't know why the date are showing different timestamp. When I modified according to my need and rebooted the machine, it is getting reset. Tried most of the options as I got in different forums (e.g., hwclock -s, rm -rf /etc/adjtime etc).

[root@mymachine ~]# date
Thu Oct 20 09:23:34 UTC 2016

[root@mymachine ~]# hwclock
Thu 20 Oct 2016 11:24:02 AM UTC  -0.302003 seconds

In some forum, people suggested vmware tools, vm can made this change. But when I checked, timesync is in disabled state.

[root@mymachine ~]# /usr/bin/vmware-toolbox-cmd timesync status
Disabled

So really not sure what is causing the date to reset or from when it has been taken?

[root@mymachine ~]# timedatectl status
      Local time: Thu 2016-10-20 09:25:47 UTC
  Universal time: Thu 2016-10-20 09:25:47 UTC
        RTC time: Thu 2016-10-20 11:26:12
        Timezone: n/a (UTC, +0000)
     NTP enabled: n/a
NTP synchronized: no
 RTC in local TZ: no
      DST active: n/a
1

Check the system bios time. If the bios time is same with OS time after reboot change the time from BIOS setup. Also, check the time zone settings you are using.

Another situation can be the CMOS Battery is not functional, if your PC is very old this may be the reason.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.