I want to have two network adapters in Kali through virtualbox. Adapter 1 will be NAT that can connect to the internet. Adapter 2 will be an internal ethernet adapter used to communicate with other VMs. Here's what I've done so far.

  1. In VirtualBox, I add a 2nd network adapter. Adapter 1 is NAT. Adapter 2 is Internal Network.
  2. Launch Kali and open the Network settings GUI. Two connections appear at this point--eth0 and eth1. eth0 is setup for DHCP which is perfect.
  3. I change eth1's IPv4 settings to assign an IP address manually. I set the address, netmask, and gateway, then click Apply.
  4. I click the toggle to enable eth1. At this point eth1 is connected, but it seems that by enabling eth1 eth0 is disconnected. If I click the toggle connect eth0, eth0 shows up with the IPv4 settings I configured for eth1 and eth1 is disconnected.

I'm not sure what I'm doing wrong. I just want two network adapters on separate networks. Any help is appreciated.

I've found your question looking for the same issue. I've seen a similar question but for a debian installation.

The recipe of force setting on the /etc/network/interfaces works but then the network-manager shows both interfaces as unmanaged. If this is not an issue for you, the ip address show assigned ip for both interfaces and ip route shows me also a default for the NAT interface (the first in fact).

I met same problem. The solution is to edit file "/etc/network/interfaces" and manually define your interfaces. All interfaces should be static!! Don't forget to run "service networking restart" as root to apply changes. All mentioned tasks should be done on the virtual machine (Kali)

first solution:(do it manually) its not possible to use one profile for both (or more) networks adapters.. so open the gnome settings in upper right of GUI, you will see the list of your networks so define new profiles for each of your network adapter and go ahead... they will work fine..

Second Solution:(force the system does it automatically)

or you can go to "/etc/NetworkManager/system-connections/" folder and delete all files which are there.. then disable and enable your network adapters ... all will goes fine... just you can go to the gnome settings in upper right of GUI (network setting) and choose each profile that you want to for each network adapter..

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.