1

I've been using a CentOS 7.1 VPS for quite some time now, and although I hadn't touched it in a while, I was doing some maintenance and noticed when I went to remove a file, I got the following message:

enter image description here

I know that strange characters can occur because of a difference in terminal or character base, but I have the following settings in env: (Removing unnecessary pieces)

SHELL=/bin/bash
TERM=xterm
LANG=en_US.UTF-8

(Note I have omitted LS_COLORS because it is insanely long, but I recognize that could also possibly be the cause.)

I've not had to deal with these kinds of characters before, so I'm kind of at a loss where to look, and I don't really want to start randomly changing settings for fear of making something worse, but basically just looking for causes of these characters. Thanks for reading.

closed as off-topic by techraf, GAD3R, HalosGhost, Jeff Schaller, Satō Katsura Oct 19 '16 at 15:57

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions describing a problem that can't be reproduced and seemingly went away on its own (or went away when a typo was fixed) are off-topic as they are unlikely to help future readers." – techraf, GAD3R, HalosGhost, Jeff Schaller, Satō Katsura
If this question can be reworded to fit the rules in the help center, please edit the question.

  • 1
    How are you accessing the VPS? it looks to me like the encoding on your (SSH?) client is set up incorrectly – steeldriver Oct 19 '16 at 14:45
  • I'm accessing via putty, but I haven't changed the putty config for ages, and this hasn't happened before. I'll check the settings nonetheless... – Tim S. Oct 19 '16 at 14:46
  • Interesting -- the character set, which has never been changed (and default set to ISO-8859-1:1998 (Latin-1, West Europe), was the culprit. I changed it to UTF and it went away. Apparently West Europe doesn't use the same type of writer-style single quotes that UTF does. (Make that an answer and I'll be glad to accept it.. so simple) – Tim S. Oct 19 '16 at 14:50
  • 1
    Should not be off-topic, because it is reproducible, and represents an issue that users of UNIX-Linux systems may face. Knowledge of character sets and their implications and impact on our systems is important to preserve. – Xalorous Oct 19 '16 at 16:23
  • @xalorous "closed" here just means that the only answer is to correct the "mistake". The question and answer aren't deleted; the closing is just a signal to focus your Answering time on other Q's. – Jeff Schaller Oct 19 '16 at 17:28
5

This looks like an encoding mismatch between your remote environment and the SSH client. In particular, PuTTY (at least on Windows) defaults to ISO-8859-1:1998 (Latin-1, West Europe) whereas you are using UTF-8 on the server side.

The PuTTY setting to correct this is under the Window -> Translation menu; go to the 'Remote character set' dropdown and select 'UTF-8'.

Not the answer you're looking for? Browse other questions tagged or ask your own question.