0

I am running tigervnc-server on CentOS 6.8, however the gnome desktop won't start for me! I have done a yum groupinstall of "X Window System", "Desktop" and "General Purpose Desktop". On one of my other CentOS VMs (v6.6), installing these packages is sufficient for having the gnome-desktop automatically startup for me when starting a vncserver.

I'm running:

vncserver :05 -geometry 2048x1024 

In /home/user/.vnc/hostname:05.log, I see:

vncconfig: unable to open display "hostname:05"
xrdb: Connection refused
xrdb: Can't open display 'hostname:05'
xmodmap: unable to open display 'hostname:05'

** (gnome-session:12313):WARNING **: Cannot open display

The VNC server starts, and I'm able to connect via vncviewer, but get a black screen.

Is there anything else I can look at to troubleshoot? The log isn't very helpful; I've been googling this problem for days, and haven't found anything that fixes it (Ex: made sure I'm in runlevel 5, I re-installed the desktop packages mentioned above, removed .vnc directory, stepped through xstartup, tried comparing various settings with my other VM where the gnome desktop is working)

Anyone know of something else I can look at to troubleshoot this issue? Any other logs, or things to check?

  • Update; it doesn't appear that the X server is being started with VNC. I attempted to run Xvnc manually, and the vncserver starts find (i see the Xnvc process listening on 5905). But I do not see Xvnc listening on port 6005, which is where the X server would be listening. No error messages are being displayed. – user1160958 Oct 18 '16 at 19:52
  • To follow up, I think I figured out the issue. It appears to be a problem specific to tigervnc v1.1.0-18. On my VM where VNC and X are working, I was running tigervnc v1.1.0-16. When I upgraded to tigervnc v1.1.0-18, this issue appeared for me where the X server doesn't start with VNC. For now, my solution will be to revert back to tigervnc-1.1.0-16. Not sure if I should make this accepted solution or not... – user1160958 Oct 19 '16 at 12:57
0

On FreeBSD, you have to edit ~/.vnc/xstartup and specify the Desktop environment. In my case I had to replace twm by startxfce4 .

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.