23

I am using gnome 3.22.1 but problem exists since 3.18.

Before that (don't remember the exact version) I was able to switch keyboard layout using xkb-witch, simple application that uses X.org bindings under the hood.

After 3.18 if you run xkb-switch, the keyboard layout won't be switched in gnome. Further investigation have shown that layout switching is working, but for a very short amount of time.

If you run this script:

for i in $(seq 1000); do
  lang=$(xkb-switch -s ru; xkb-switch);
  if [[ "$lang" == "ru" ]]; then
    echo $lang;
  fi;
done

You will get from 3 to 20 "successfull" layout switchings, depending on how lucky you are.

After googling this problem I the following advice:

gsettings set org.gnome.desktop.input-sources current 0

The setting is being changed, but the layout stays the same.

I have found one "hacky" method to change the layout:

setxkbmap us,ru
setxkbmap ru,us

but the gnome shell isn't aware of that change, and shows wrong language in layout indicator.

I've posted about this problem (sorry, not enough reputation, https ://bbs.archlinux.org/viewtopic.php?pid=1657582 https ://github.com/ierton/xkb-switch/issues/15), but had no luck getting any good answers.

And at this point I'm stuck. I'm not skilled enough to identify the problem in gnome shell code. I'm not even sure it is it's(gnome shell's) problem.

What I want is a gnome-aware way to switch keyboard layout from terminal. Can someone point me in the right direction? Should I file this as a bug (especially the fact that keyboard layout cannot be changed through gsettings)?

0

6 Answers 6

17

Since gnome-shell exposes a JS eval interface on DBus which has access to all variables, the feat is possible with the following command:

gdbus call --session --dest org.gnome.Shell \
--object-path /org/gnome/Shell \
--method org.gnome.Shell.Eval \
 "imports.ui.status.keyboard.getInputSourceManager().inputSources[0].activate()"

Which will activate 0th layout, and so forth. It is trivial to assign these commands to, say, underutilized 無変換 and 変換 on your Japanese keyboard.

Credit.


And this is how to switch to last used input method (from comments):

gdbus call --session --dest org.gnome.Shell --object-path /org/gnome/Shell \
--method org.gnome.Shell.Eval "imports.ui.status.keyboard.getInputSourceManager()._mruSources[1].activate()"
3
  • 3
    Thank you for your answer – it saved me a lot of googling! And this is how to switch to last used input method: gdbus call --session --dest org.gnome.Shell --object-path /org/gnome/Shell --method org.gnome.Shell.Eval "imports.ui.status.keyboard.getInputSourceManager()._mruSources[1].activate()"
    – Envek
    Jan 8, 2019 at 19:35
  • This. Works exactly the same as keyboard shortcut. Sep 25, 2021 at 19:58
  • 1
    These commands doesn't work anymore after upgrade from gnome-shell 40 to 41 because Gnome restricted to use eval due to security reasons. Possible workaround is to wrap them into custom extensions. I wrapped my switcher to last used layout here: gist.github.com/Envek/85f40478d1c8b9658621190569046447
    – Envek
    Nov 22, 2021 at 17:52
8
+25

If you are using IBus as your input method (which is a likely default), you can change your input using the ibus command:

# Set the layout to US English
ibus engine xkb:us::eng
# Set the input method to Japanese Mozc IME
ibus engine mozc-jp
# Set the layout to Russian
ibus engine xkb:ru::rus

You can see all available layouts with the ibus list-engine command.

It must be noted this approach does not change the language indicator, although it works reliably otherwise.

10
  • That's same as setxkbmap us - with no way to change layout using standard shortcuts after that.
    – sanmai
    Jun 16, 2018 at 2:32
  • @sanmai Not quite the same — it's impossible to switch to languages needing IME (Japanese, Chinese, etc) using setxkbmap. Furthermore, setxkbmap can act plain buggy in modern WM environments, see the question for details on this.
    – undercat
    Jun 16, 2018 at 3:17
  • Can't comment on the default shortcuts not working though — I'm using custom ones for every layout that I use.
    – undercat
    Jun 16, 2018 at 3:20
  • OK, not the same, but still I can't use the default switch. As you may know, there's only as much extra keys on a Japanese keyboard, for other layouts I still have to use the default switch.
    – sanmai
    Jun 16, 2018 at 3:22
  • @undercatapplaudsMonica Do you have any advice on how to make the change persistent between reboots (aside from calling it in an autostart file on startup)?
    – AdminBee
    Sep 16, 2020 at 14:31
5

You can set up and switch to an input method on the command line even if you have not previously set up that input method with the mouse:

gsettings set org.gnome.desktop.input-sources sources "[('xkb', 'ru')]"

For Dvorak, use us+dvorak (or gb+dvorak if you're in the UK, or whatever).

4

Using gsettings.

Setting org.gnome.desktop.input-sources.sources to the null list, "[]", allows you to use the X server keyboard configuration without gnome-shell trying to configure it, so you could be able to do as before.

$ gsettings set org.gnome.desktop.input-sources sources '[]'
1
  • 1
    When I tried this, my Gnome Terminal got stuck on QWERTY no matter how many setxkbmap commands I typed afterward, until I put the input sources back via the Settings dialogue. Mar 25, 2019 at 12:56
0

I think you should try sudo dpkg-reconfigure keyboard-configuration

0

Gnome overrides xkb options according to this other post. As a consequence, this output:

$ dconf read /org/gnome/desktop/input-sources/xkb-options
['grp:alt_shift_toggle','grp_led:scroll']
1

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.