2

I'm dual-booting kali linux with windows 10. While boot installation kali linux asks for:

Some of your hardware needs non-free firmware files to operate. The firmware can be loaded from removable media, such as a USB stick or floppy.

The missing firmware files are: iwlwifi-7265D-21.ucode iwlwifi-7265D-20.ucode iwlwifi-7265D-19.ucode iwlwifi-7265D-18.ucode iwlwifi-7265D-17.ucode iwlwifi-7265D-16.ucode iwlwifi-7265D-15.ucode iwlwifi-7265D-14.ucode iwlwifi-7265D-13.ucode rtl_nic/rtl8107e-2.fw If you have media available now, insert it, and continue.

Load missing firmware from removable media? No Yes

I've already tried this solution but It doesn't work. It suggests to download non-free firmware from here. I downloaded and extract firmware.zip and extracted into FAT 32 USB.

When I tap on Yes to allow installer to load missing firmware from USB, that same page is again displayed and it again asked me to load firmware. It means installer is not actually detecting firmwares from removable USB.

It might be because the firmwares I extracted from the firmware.zip are not the one installer is asking for?

These are the list of files which installer is demanding for. I copied them in FAT32 USB but installer is not detecting them:

firmwares What am I missing?

1

Following this answer (it's a working solution), after downloading and extracting the firmware.zip file, you need to extract the firmware-iwlwifi_0.43_all.deb file (under MS Windows you can use altap Salamander) then extract the data.tar.xz go to /data/lib/firmware and copy all the contents to your USB (Fat32).

Or simply download iwlwifi firmware from here.

It's the same to install rtl_nic/rtl8107e-2.fw

Download the firmware-realtek_20160824-1_all.deb, extract it.

extract the data.tar.xz file.

The needed firmware will be found at /data/lib/firmware/rtl_nic/rtl8107e-2.fw. Copy it to your USB. Reboot for installation; when you are invited to load the missing firmware, plug in your USB stick. The firmware will be detected and installed without problem.

  • I should've mentioned that. On my first encounter with this problem I just directly downloaded the .ucode files from github (this link you have already mentioned). I copied the ucode files and fw file into my FAT 32 USB but installer didn't detect it. This method is far more easy than extracting part. Am I missing something? While installing I plug second USB in which these firmwares are copied. The first USB is my bootable USB of kali linux. – defalt Oct 17 '16 at 11:28
  • I uploaded a screenshot of firmware list I've downloaded. Have I done anything wrong? – defalt Oct 17 '16 at 14:51
  • copy only the rtl_nic/rtl8107e-2.fw to your usb stick , what is the result? – GAD3R Oct 18 '16 at 16:27
  • Result is nothing happens. That step is again displayed and asks for missing file. I think Installer is not detecting it. I don't know why it's happening, I searched the entire internet for my solution. It sounds like I'm the only one with this problem. I've last option. I can skip that step by clicking on No and then install them after installation using command line. – defalt Oct 18 '16 at 16:59
  • The installer is supposed to copy whatever is there in my USB. – defalt Oct 18 '16 at 17:01
0

Or simply download iwlwifi firmware from here

This is the easiest solution. Two remarks:

  1. The link provided didn't work for me since the network detect required an older version of the firmware than was available at the repo. I googled the exact version and found it here.
  2. Don't wait to insert the firmware USB until you are asked to. Just boot into installation with both USB sticks inserted. This way the Kali install will find it.
0

I also had the same problem. I was directed and solved my issue by creating a bootable USB using Rufus v2.18 to dual boot my FAT32 usb with the Linux iso as DD image file. So basically Dual boot the usb and Linux using Rufus v2.18 as a DD image file not ISO and it should be fine !

0

How I got it fixed: on the FAT32 USB drive with Kali Linux installer on it, there's a folder called firmware, but all files there are empty. So I went to pool/non-free/f/firmware-nonfree and copied all files to the firmware folder and allowed replacement. I also opened those .deb files I needed with 7zip, in 7zip I opened data.tar.xz/./lib/firmware and copied files from there to the root of the USB. (For Realtek device I copied the rtl_nic folder)

0

Goto this awesomedetect.com/how-to-provide-non-free-firmware-files-to-kali-linux-installer if you are still confused after reading the answer below. The process is well documented with great details there.

Hey there I know this is an old post but I hope my answer will be helpful to many people. I'm answering this question because a few days back while I was attempting to dual boot Kali Linux I faced the exact same problem and came here hoping to get some help and I did get help to a great extent. After some trial and error, I solved the problem and documented the process.

1- live boot Kali Linux on your system to see if wifi and ethernet work fine in live boot or not. if wifi works fine on live boot then you don't even need to download anything from anywhere because non-free firmware files for most common wifi cards are already provided in kali Linux.

2- If your wifi works fine on live boot then you may skip this step. If your wifi doesn't work in live boot then you need to search and download required files from debian.org.

3- Copy all .deb files from this directory of your kali live boot usb : pool/non-free/firmware subdirectories to /firmware which is located in root of kali installation directory. If you downloaded any files during above step then include them in the same directory. just copy them no need to extract them.

4- start the installation process and all will be as expected.

thanks have a good day.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.