1

I have a Thinkpad T410 on which I run Arch Linux. I'm using pulseaudio as well. Sound seems to work properly: pulse starts, it seems to recognize and play nice with alsa, I can the proper stuff happening in the 'Playback' tab on pavucontrol when playing audio, etc. I even get sound out of my speakers. But, eventually, inexplicably, my speakers stop producing sound. Everything else seems to keep right on keeping on. I have not been able to determine what triggers this, so I cannot easily reproduce the issue. Here is what I know

  1. Restarting brings sound back
  2. The loss of sound appears to be time-based. I would say within an hour of playing a stream I lose sound
  3. The sound only goes away when there is an audio stream playing: if I reboot and leave the computer alone for a week and then play a stream, I get audio
  4. Pulse does appear to still be operating. I can plug in my headphones and listen to the audio streams, and I can also connect an external DAC and play audio through that

I'm at a loss as to what further debugging steps to take. What can I do to track down what is causing this issue and fix it?

  • A reasonable first step would be to try a different distribution and see if you have the problem there. – Faheem Mitha Oct 16 '16 at 22:09
  • IIRC pulseaudio uses a daemon and binds streams. You should verify that the daemon is still running, and that your streams are still bound. – CodeGnome Oct 17 '16 at 2:10
  • CodeGnome: the fact that I get audio through pulse via other output devices, namely the headphone jack and the usb s/pdif, doesn't suggest that the pulse daemon is still running? @FaheemMitha I'm not so sure I'd consider that a "reasonable" first step. I do think it'd be worth trying, but are there not other less extreme things I could check first? – wesanyer Oct 17 '16 at 15:43
  • 1
    @wesanyer Why is it extreme? It's not much work to do an installation. And you can also use a live distribution. I'd personally try Debian or Ubuntu in the first instance. – Faheem Mitha Oct 17 '16 at 17:04
  • Fair enough, a live cd seems reasonable. I just don't like repartitioning bc it is not a trivial task. – wesanyer Oct 17 '16 at 17:25
0

Sorry for the false alarm. The problem is still showing up on my laptop as well.

I did find a hack though: close the lid, wait for the beep confirming it went to sleep and then open the lid. It's not a solution but it's quite a bit faster than rebooting.

  • thanks for the tip. I don't think my gentoo kernal has DKMS enabled. – wesanyer Jul 17 '17 at 16:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.