I am following the "even better method" documented here:


I am unable to get it to work. I follow all the steps, but end up with no access to the windows share.


1) Where is the autofs log file , so I can debug? (I already set the log option in autofs.conf to verbose)

2) my auto.mymount is:

WindowsServer  -fstype=cifs,rw,noperm,user=localuser\backupuser,pass=cheesy ://winhost.mydomain.com/backups

I think the "localuser\backupuser" is a poss problem. But that server is in a domain, so I need to specify where the user lives. How to handle?

Suggestions and guidance welcome.

  • \b likely a problem. Man page for mount.cifs ( linux.die.net/man/8/mount.cifs ) says use simply /, so localuser/backupuser in your case. – steve Oct 16 '16 at 21:33
  • @steve Thanks. Tried that, still doesnt work. Where does autofs keep logs? – samsmith Oct 16 '16 at 21:35
  • File /etc/sysconfig/autofs, add OPTIONS="--debug" and then restart autofs. Hey presto, debug info in /var/log/messages. – steve Oct 16 '16 at 21:42
  • 1
    Is this a duplicate of unix.stackexchange.com/q/316820/117549 ? – Jeff Schaller Oct 16 '16 at 23:13

How to debug:

  1. modify /etc/sysconfig/autofs. Append this line at the end: OPTIONS="--debug"

How to resolve your issue: suppose you want to bind Linux /mnt/remote/WindowsServer with Windows shared folder //winhost.mydomain.com/backups. At winhost.mydomain.com you've registered local user 'backupuser'. You have already installed and started nfs and autofs services.

  1. add below line at /etc/auto.master :

    /mnt/remote    /etc/auto.mymount  --timeout=60
  2. add below line at /etc/auto.mymount :

    WindowsServer  -fstype=cifs,rw,noperm,domain=winhost,user=backupuser,pass=cheesy ://winhost.mydomain.com/backups
  3. restart autofs:

    sudo systemctl restart autofs

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.