-1

I've successfully been able to configure the latest Firefox (source) without errors. All the required dependencies are in place (i.e. GCC 4.9.2 via devtoolset-3, Python 2.7, Yasm, libffi 3.2.1, and on). When I run ./mach build it also successfully configures and starts makeing the binaries... then after about 24 minutes it chokes on

24:40.15 /home/osboxes/firefox-50.0b7/gfx/thebes/gfxFontconfigFonts.cpp: In member function ‘virtual already_AddRefed<gfxFont> gfxPangoFontGroup::FindFontForChar(uint32_t, uint32_t, uint32_t, gfxFontGroup::Script, gfxFont*, uint8_t*)’:
24:40.15 /home/osboxes/firefox-50.0b7/gfx/thebes/gfxFontconfigFonts.cpp:1628:66: error: ‘g_unicode_script_from_iso15924’ was not declared in this scope
24:40.15        (const PangoScript)g_unicode_script_from_iso15924(scriptTag);
24:40.15                                                                   ^

The pertinent part being

‘g_unicode_script_from_iso15924’ was not declared in this scope

I searched online for this error first and the only reference to this is a fixed bug in v52 (ref) which isn't even in the sources repo at this time. This isn't a bug.

How to compile Firefox 50 for a system using GLibc 2.12?


Solved: I discovered that g_unicode_script_from_iso15924 is a new symbol in GLib 2.30 (ref). Glib needs to be updated to at least version 2.30.

0

That's not a symbol in glibc, it's a symbol in GLib. If you build and install GLib 2.30 or later, you should be able to build Firefox 50.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.