1

I would like to disable the auto-mute feature and tried to do so by deactivating it in AlsaMixer. Unfortunetaly, this does not work. The setting is being ignored.

When I start AlsaMixer it shows only two controls (Master and Capture), although I've already set "View" to "All":

AlsaMixer default

I think this is because the default sound chip is PulseAudio?!

This is what AlsaMixer shows me when I select a sound card:

AlsaMixer default sound chip

...when I change the sound card to HDA Intel PCH I have the whole control set that I am familiar with from my desktop computer:

enter image description here

Notice that sound chip now says Realtek ALC293, which is correct. However, the disabled Auto-Mute there is being ignored by any application.

How can I make Alsa use Realtek ALC2293 by default? Or is there any way to disable auto-mute in PulseAudio (my system uses PulseAudio)?

I am using Manjaro (Arch Linux) with Kernel 4.7.7-1.

  • That control is implemented by the hardware. If PulseAudio does its own automuting, you have to disable it there. – CL. Oct 15 '16 at 19:54
  • I do not know if PulseAudio does auto-muting. At least I did not find any information nor setting for auto-muting in PulseAudio. However, it has to be either AlsaMixer that selects the PulseAudio chip and ignores the disabled auto-mute on Realtek ALC293 or PulseAudio has its own auto-mute option, because auto-mute is still working. – daniel451 Oct 15 '16 at 20:43
  • Could you describe what exactly is auto muted in what situation? Pulseaudio already uses the Alsa hardware, and the PulseAudio "sound chip" only allows Alsa applications to use PulseAudio, it's not real hardware. So if you disabled the hardware auto-muting, then either this auto-muting works differently than you think, or something else auto-mutes (whatever it is that gets muted). – dirkt Oct 16 '16 at 7:07
  • Whenever I launch applications like Mumble, TeamSpeak, Skype, IP phone software, and so on other applications get muted (like VLC Player, Amarok, Spotify, ...). I googled and found out that others solved this by deactivating auto-mute in alsamixer. However, this does not work for me. I thought this may be because of the PulseAudio chip (that virtual thing) being the default sound chip instead of the Realtek ALC293. – daniel451 Oct 16 '16 at 7:57
  • First step to debug: run pavucontrol and look what happens when you start a new application. In principle, pulseaudio should handle the "mixing" (several apps on one sink), and just forward the mixed stream to the ALSA driver, so ALSA auto-mute shouldn't have anything to do with it. But who knows ... – dirkt Oct 16 '16 at 17:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.