0

I'm running a debian-wheezy based distro on an a set of armv5 boards. If I run the "reboot" command (either via ssh or serial console), it works fine most of the time. Occasionally (approximately every 50 or so reboots, but not consistently), the system hangs on the shutdown part of the reboot. When it hangs, the network is still enabled and the firewall is still running (because it still forwards packets). But sshd is not running, nor my own software.

During a normal reboot, I see this printed to the console:

...
[ ok ] Unmounting temporary filessytems...done. 
[ ok ] Deactivating swap...done.
[info] Will now restart.

>> TS-BOOTROM - built Jul   8 2013 15:44:26
>> Copyright (c) 2012, Technologic Systems
.
.
Uncompressing Linux... done, booting the kernel.
...

When it fails, I see:

...
[ ok ] Unmounting temporary filessytems...done. 
[ ok ] Deactivating swap...done.
kexec: No such file or directory
reboot: No such file or directory
/etc/init.d/rc: 279: /etc/init.d/rc: /bin/echo: not found
/etc/init.d/rc: 364: /etc/init.d/rc: /bin/echo: not found
INIT: cannot execute "/sbin/sulogin"
... (repeats ten times)
INIT: Id "z6" respawning too fast: disabled for 5 minutes

I tried lookingin /etc/init.d/rc for the lines shown above (279, 364), but the file only has 256 lines. So that's weird...

It seems to me that a script is trying to run after the file system has been unmounted, but only occasionally. Most of the time it's fine. Now, when I look in /etc/rc6.d, I see K07umountfs, K08umountroot, K09kexec, and K10reboot. So it seems kexec and reboot are supposed to run after file system unmounting (and it works ~99% of the time).

I'm kind of stuck now. I would appreciate any help, even if it just points me in the right direction.

1

I'm late on this issue, but I'm one of the developers at Technologic. It looks like this is the TS-47xx family or the TS-7250-V2. If you're still having this issue please contact our support. We fixed some rare NBD issues early in development on this product that could possibly be the issue. More commonly this happens from running on SD cards and disconnecting power without properly shutting down. If none of these are the case we can set up a test with several boards constantly rebooting to attempt to reproduce this.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.