4

How can I replace XFCE4 window manager with awesome?

I tried to place the following content to the ~/.xinitrc file:

#!/bin/sh

exec awesome

I also tried to do this stuff:

xfconf-query -c xfce4-session -p /sessions/Failsafe/Client0_Command -t string -s "awesome" -a

And it doesn't work. Of course I already installed awesome via

sudo apt-get install awesome
  • Don't forget to clear your session! After running that command, xfwm4 will still be started because it was running in your last session. Clearing your session will prevent that. – josch Aug 11 '18 at 9:11
5

from https://awesomewm.org/wiki/Awesome_and_Xfce4

  1. Go to: Settings -> Session and Startup -> Session

  2. And change Restart Style of xfwm4 to Never

  3. Then go to Application Autostart and add awesome

It should work after restarting xfce

4

On the fly, you can type :

killall xfwm4 && awesome &

To exchange permanently, you can edit /etc/xdg/xfce4/xfconf/xfce-perchannel-xml/xfce4-session.xml and replace xfwm4 with awesome.

  • Many window managers also have a --replace option, like so: awesome --replace&, called from a shell or startup option. However, I do not have awesome so I cannot test it. – Ned64 Oct 15 '16 at 12:21
  • 1
    @Ned64 awesomewm does not currently have the --replace flag (as of v3.5.9) – Lawful Lazy Dec 17 '16 at 18:13
  • 2
    But it seems to be present in Awesome 4.2. – Rovanion Feb 7 '18 at 9:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.