0

I had issues with 1.2.x version of insync, so I googled for its website and I downloaded the deb file of the newest version for my 64 bit debian. dpkg couldn't install it, even setting the --force-all option, the output is

   ale@debian:~/Scaricati$ sudo dpkg --force-all -i insync_1.3.12.36116-wheezy_amd64.deb 
   [sudo] password for ale:          
   (Reading database ... 342721 files and directories currently installed.)
   Preparing to unpack insync_1.3.12.36116-wheezy_amd64.deb ...
   Traceback (most recent call last):
     File "<string>", line 5, in <module>
   zipimport.ZipImportError: not a Zip file: '/usr/lib/insync/library.zip'
   dpkg: warning: subprocess old pre-removal script returned error exit status 1
   dpkg: trying script from the new package instead ...
   Traceback (most recent call last):
     File "<string>", line 5, in <module>
   zipimport.ZipImportError: not a Zip file: '/usr/lib/insync/library.zip'
   dpkg: error processing archive insync_1.3.12.36116-wheezy_amd64.deb (--install):
    subprocess new pre-removal script returned error exit status 1
   Traceback (most recent call last):
     File "<string>", line 5, in <module>
   zipimport.ZipImportError: not a Zip file: '/usr/lib/insync/library.zip'
   *** Error in `dpkg': munmap_chunk(): invalid pointer: 0x000055edcb3d9751 ***
   ======= Backtrace: =========
   /lib/x86_64-linux-gnu/libc.so.6(+0x3d93a70bcb)[0x7f34a30b2bcb]
   /lib/x86_64-linux-gnu/libc.so.6(+0x3d93a76fa6)[0x7f34a30b8fa6]
   dpkg(+0x20060)[0x55edc8b7c060]
   dpkg(+0x204b9)[0x55edc8b7c4b9]
   dpkg(+0x277fa)[0x55edc8b837fa]
   dpkg(+0x16b07)[0x55edc8b72b07]
   dpkg(+0x16ce5)[0x55edc8b72ce5]
   dpkg(+0x16f2d)[0x55edc8b72f2d]
   dpkg(+0xa297)[0x55edc8b66297]
   dpkg(+0x1ff9b)[0x55edc8b7bf9b]
   dpkg(+0x201a1)[0x55edc8b7c1a1]
   dpkg(+0x9d22)[0x55edc8b65d22]
   dpkg(+0x66a9)[0x55edc8b626a9]
   /lib/x86_64-linux-gnu/libc.so.6(__libc_start_main+0xf1)[0x7f34a30622b1]
   dpkg(+0x67e9)[0x55edc8b627e9]
   ======= Memory map: ========
   55edc8b5c000-55edc8ba0000 r-xp 00000000 08:06 5505633                    /usr/bin/dpkg
   55edc8da0000-55edc8da3000 r--p 00044000 08:06 5505633                    /usr/bin/dpkg
   55edc8da3000-55edc8da4000 rw-p 00047000 08:06 5505633                    /usr/bin/dpkg
   55edc8da4000-55edc8fb8000 rw-p 00000000 00:00 0 
   55edcac76000-55edceccb000 rw-p 00000000 00:00 0                          [heap]
   7f34a1bff000-7f34a1c15000 r-xp 00000000 08:06 5637055                    /lib/x86_64-linux-gnu/libgcc_s.so.1
   7f34a1c15000-7f34a1e14000 ---p 00016000 08:06 5637055                    /lib/x86_64-linux-gnu/libgcc_s.so.1
   7f34a1e14000-7f34a1e15000 rw-p 00015000 08:06 5637055                    /lib/x86_64-linux-gnu/libgcc_s.so.1
   7f34a1e15000-7f34a2170000 rw-p 00000000 00:00 0 
   7f34a2170000-7f34a217a000 r-xp 00000000 08:06 5637413                    /lib/x86_64-linux-gnu/libnss_files-2.24.so
   7f34a217a000-7f34a237a000 ---p 0000a000 08:06 5637413                    /lib/x86_64-linux-gnu/libnss_files-2.24.so
   7f34a237a000-7f34a237b000 r--p 0000a000 08:06 5637413                    /lib/x86_64-linux-gnu/libnss_files-2.24.so
   7f34a237b000-7f34a237c000 rw-p 0000b000 08:06 5637413                    /lib/x86_64-linux-gnu/libnss_files-2.24.so
   7f34a237c000-7f34a2382000 rw-p 00000000 00:00 0 
   7f34a2382000-7f34a238d000 r-xp 00000000 08:06 5637477                    /lib/x86_64-linux-gnu/libnss_nis-2.24.so
   7f34a238d000-7f34a258c000 ---p 0000b000 08:06 5637477                    /lib/x86_64-linux-gnu/libnss_nis-2.24.so
   7f34a258c000-7f34a258d000 r--p 0000a000 08:06 5637477                    /lib/x86_64-linux-gnu/libnss_nis-2.24.so
   7f34a258d000-7f34a258e000 rw-p 0000b000 08:06 5637477                    /lib/x86_64-linux-gnu/libnss_nis-2.24.so
   7f34a258e000-7f34a25a2000 r-xp 00000000 08:06 5639731                    /lib/x86_64-linux-gnu/libnsl-2.24.so
   7f34a25a2000-7f34a27a2000 ---p 00014000 08:06 5639731                    /lib/x86_64-linux-gnu/libnsl-2.24.so
   7f34a27a2000-7f34a27a3000 r--p 00014000 08:06 5639731                    /lib/x86_64-linux-gnu/libnsl-2.24.so
   7f34a27a3000-7f34a27a4000 rw-p 00015000 08:06 5639731                    /lib/x86_64-linux-gnu/libnsl-2.24.so
   7f34a27a4000-7f34a27a6000 rw-p 00000000 00:00 0 
   7f34a27a6000-7f34a27ad000 r-xp 00000000 08:06 5637380                    /lib/x86_64-linux-gnu/libnss_compat-2.24.so
   7f34a27ad000-7f34a29ac000 ---p 00007000 08:06 5637380                    /lib/x86_64-linux-gnu/libnss_compat-2.24.so
   7f34a29ac000-7f34a29ad000 r--p 00006000 08:06 5637380                    /lib/x86_64-linux-gnu/libnss_compat-2.24.so
   7f34a29ad000-7f34a29ae000 rw-p 00007000 08:06 5637380                    /lib/x86_64-linux-gnu/libnss_compat-2.24.so
   7f34a29ae000-7f34a29c6000 r-xp 00000000 08:06 5636302                    /lib/x86_64-linux-gnu/libpthread-2.24.so
   7f34a29c6000-7f34a2bc5000 ---p 00018000 08:06 5636302                    /lib/x86_64-linux-gnu/libpthread-2.24.so
   7f34a2bc5000-7f34a2bc6000 r--p 00017000 08:06 5636302                    /lib/x86_64-linux-gnu/libpthread-2.24.so
   7f34a2bc6000-7f34a2bc7000 rw-p 00018000 08:06 5636302                    /lib/x86_64-linux-gnu/libpthread-2.24.so
   7f34a2bc7000-7f34a2bcb000 rw-p 00000000 00:00 0 
   7f34a2bcb000-7f34a2bcd000 r-xp 00000000 08:06 5636507                    /lib/x86_64-linux-gnu/libdl-2.24.so
   7f34a2bcd000-7f34a2dcd000 ---p 00002000 08:06 5636507                    /lib/x86_64-linux-gnu/libdl-2.24.so
   7f34a2dcd000-7f34a2dce000 r--p 00002000 08:06 5636507                    /lib/x86_64-linux-gnu/libdl-2.24.so
   7f34a2dce000-7f34a2dcf000 rw-p 00003000 08:06 5636507                    /lib/x86_64-linux-gnu/libdl-2.24.so
   7f34a2dcf000-7f34a2e41000 r-xp 00000000 08:06 5636499                    /lib/x86_64-linux-gnu/libpcre.so.3.13.3
   7f34a2e41000-7f34a3040000 ---p 00072000 08:06 5636499                    /lib/x86_64-linux-gnu/libpcre.so.3.13.3
   7f34a3040000-7f34a3041000 r--p 00071000 08:06 5636499                    /lib/x86_64-linux-gnu/libpcre.so.3.13.3
   7f34a3041000-7f34a3042000 rw-p 00072000 08:06 5636499                    /lib/x86_64-linux-gnu/libpcre.so.3.13.3
   7f34a3042000-7f34a31d7000 r-xp 00000000 08:06 5636270                    /lib/x86_64-linux-gnu/libc-2.24.so
   7f34a31d7000-7f34a33d6000 ---p 00195000 08:06 5636270                    /lib/x86_64-linux-gnu/libc-2.24.so
   7f34a33d6000-7f34a33da000 r--p 00194000 08:06 5636270                    /lib/x86_64-linux-gnu/libc-2.24.so
   7f34a33da000-7f34a33dc000 rw-p 00198000 08:06 5636270                    /lib/x86_64-linux-gnu/libc-2.24.so
   7f34a33dc000-7f34a33e0000 rw-p 00000000 00:00 0 
   7f34a33e0000-7f34a3404000 r-xp 00000000 08:06 5636565                    /lib/x86_64-linux-gnu/libselinux.so.1
   7f34a3404000-7f34a3603000 ---p 00024000 08:06 5636565                    /lib/x86_64-linux-gnu/libselinux.so.1
   7f34a3603000-7f34a3604000 r--p 00023000 08:06 5636565                    /lib/x86_64-linux-gnu/libselinux.so.1
   7f34a3604000-7f34a3605000 rw-p 00024000 08:06 5636565                    /lib/x86_64-linux-gnu/libselinux.so.1
   7f34a3605000-7f34a3607000 rw-p 00000000 00:00 0 
   7f34a3607000-7f34a362a000 r-xp 00000000 08:06 5636259                    /lib/x86_64-linux-gnu/ld-2.24.so
   7f34a3662000-7f34a37fb000 r--p 00000000 08:06 5505564                    /usr/lib/locale/locale-archive
   7f34a37fb000-7f34a37fd000 rw-p 00000000 00:00 0 
   7f34a3825000-7f34a3829000 rw-p 00000000 00:00 0 
   7f34a3829000-7f34a382a000 r--p 00022000 08:06 5636259                    /lib/x86_64-linux-gnu/ld-2.24.so
   7f34a382a000-7f34a382b000 rw-p 00023000 08:06 5636259                    /lib/x86_64-linux-gnu/ld-2.24.so
   7f34a382b000-7f34a382c000 rw-p 00000000 00:00 0 
   7fffe1f34000-7fffe1f55000 rw-p 00000000 00:00 0                          [stack]
   7fffe1f9e000-7fffe1fa0000 r--p 00000000 00:00 0                          [vvar]
   7fffe1fa0000-7fffe1fa2000 r-xp 00000000 00:00 0                          [vdso]
   ffffffffff600000-ffffffffff601000 r-xp 00000000 00:00 0                  [vsyscall]
   Aborted

So I said "who cares about insync, nautilus has google drive integration", so I decided to uninstall insync but I couldn't. Now, magically, I cannot run anymore apt-get upgrade or aptitude upgrade, I get this error output:

   Resolving dependencies...               
   The following partially installed packages will be configured:
  insync
   No packages will be installed, upgraded, or removed.
   0 packages upgraded, 0 newly installed, 0 to remove and 1 not upgraded.
   E: Can't find a source to download version '1.3.10.36104-wheezy' of 'insync:amd64'
   After unpacking 0 B will be used.
   E: Can't find a source to download version '1.3.10.36104-wheezy' of 'insync:amd64'
   E: Internal error: couldn't generate list of packages to download
   E: Perhaps the package lists are out of date, please try 'aptitude update' (or equivalent) first

This maybe because the insync repo is unaccessable (which is, for the record, this one).

What's more, I can't even open synaptic without getting this nice error:

   An error occurred
   the following details are prodived
   E: dpkg was interrupted, you must manually run 'sudo dpkg --configure -a' to correct the problem.
   E: _cache->open() failed, please report.

of course insync is the cause of all this:

   ale@debian:~/Scaricati$ sudo dpkg --audit && echo ok
   The following packages are in a mess due to serious problems during
   installation.  They must be reinstalled for them (and any packages
   that depend on them) to function properly:
    insync               Google Drive sync and backup with multiple    account suppor

What can I do, what can be done to solve this hideous situation and have my daily package upgrade back? Thank you all in advance.

  • Did you run sudo dpkg --configure -a? – agc Oct 13 '16 at 19:58
  • of course I did. The output is ale@debian:~/Scaricati$ sudo dpkg --configure -a dpkg: error processing package insync (--configure): package is in a very bad inconsistent state; you should reinstall it before attempting configuration Errors were encountered while processing: insync – Ale Oct 13 '16 at 20:05
  • How about purge: dpkg -P insync? – agc Oct 13 '16 at 20:10
  • the same ale@debian:~/Scaricati$ sudo dpkg -P insync dpkg: error processing package insync (--purge): package is in a very bad inconsistent state; you should reinstall it before attempting a removal Errors were encountered while processing: insync – Ale Oct 13 '16 at 20:19
  • Based on Ipugoy's comment on this thread try running this mv /var/lib/dpkg/info/insync.prerm ~/insync.prerm.bak, and then purge or remove as before. – agc Oct 13 '16 at 20:34
0

I solved in another way I found online: I removed insync entry in

   /var/lib/dpkg/status, 

did

   apt-get update && sudo apt-get upgrade 

again and everything started working fine back

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.