I used to have a Samsung Galaxy Fit that worked out of the box with Banshee.

I recently bought a new Sony Ericsson Xperia Mini, I tried to sync it using Banshee, but it doesn't show up.

It does mount when I switch to Mass Storage mode, and I can see it using lsusb but running mtp-detect outputs No raw devices found.

I'm running Gnome 3 on Arch Linux.


According to the libmtp homepage (the source of mtp-detect):

If you happen upon a device which libmtp claims it cannot autodetect, please:

  • Submit the vendor ID and device ID as a bug, patch or feature request on the Sourceforge bug tracker at our homepage.
  • If it gives a sensible output from "mtp-detect" then please attach the result as well as it teaches us some stuff about your device.
  • If it doesn't give sensible output, attach the output from "lsusb -v" for your device.
  • If you want to be able to hack some more and you're not afraid of C hacking, add an entry for your device's vendor/product ID and a descriptive string to the database in the file src/music-players.h.
  • If you want to poke around to see if your device has some special peculiarities, you can test some special device flags defined in src/device-flags.h by inserting them together with your device entry in src/music-players.h. Flags can be tested in isolation or catenated with "|" (binary OR). If relatives to your device use a certain flag, chances are high that a new device will need it too, typically from the same manufacturer. The most common flag that needs to be set is the DEVICE_FLAG_UNLOAD_DRIVER that detach any Linux kernel drivers that may have attached to the device making MTP access impossible.
  • I'll try and do that, but it's not an mtp problem, it also doesn't show up when I use it as removable storage. – Mahmoud Hossam Feb 14 '12 at 8:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.