0

I installed Linux mint on my HP-OMEN laptop and cannot get wifi working, it just doesn't enabling. (I press enable wifi and happeds one of two things: 1)Nothing 2)Wifi start rapidly enabling/disabling with interval about second).
iwconfig log

wlp9s0    IEEE 802.11abgn  ESSID:off/any  
      Mode:Managed  Access Point: Not-Associated   Tx-Power=0 dBm   
      Retry short limit:7   RTS thr:off   Fragment thr:off
      Power Management:on

lo        no wireless extensions.

Actions that i need to preform to cause second variant of enabling work (Rapid enable/disable)

igor@igor-HP-OMEN-Notebook ~ $ rfkill list 
0: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no
1: acer-wireless: Wireless LAN
    Soft blocked: yes
    Hard blocked: no
2: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no
igor@igor-HP-OMEN-Notebook ~ $ rfkill unblock 1
igor@igor-HP-OMEN-Notebook ~ $ rfkill list 
0: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no
1: acer-wireless: Wireless LAN
    Soft blocked: yes
    Hard blocked: no
2: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no
igor@igor-HP-OMEN-Notebook ~ $ rfkill block all
igor@igor-HP-OMEN-Notebook ~ $ rfkill list 
0: hci0: Bluetooth
    Soft blocked: yes
    Hard blocked: no
1: acer-wireless: Wireless LAN
    Soft blocked: no
    Hard blocked: no
2: phy0: Wireless LAN
    Soft blocked: yes
    Hard blocked: no
igor@igor-HP-OMEN-Notebook ~ $ rfkill unblock 2
igor@igor-HP-OMEN-Notebook ~ $ rfkill list 
0: hci0: Bluetooth
    Soft blocked: yes
    Hard blocked: no
1: acer-wireless: Wireless LAN
    Soft blocked: yes
    Hard blocked: no
2: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no

(Writing this question from windows)

UPD

lspci -knn | grep Net -A2 log

09:00.0 Network controller [0280]: Intel Corporation Wireless 7260 [8086:08b1] (rev c3)
Subsystem: Intel Corporation Dual Band Wireless-AC 7260 [8086:c070]
Kernel driver in use: iwlwifi
  • Welcome to U&L , please add the output of lspci -knn | grep Net -A2 – GAD3R Oct 14 '16 at 7:44
0

Ok, problem solved by running those commands and rebooting:

sudo modprobe -r acer_wmi
sudo rfkill unblock all
echo "blacklist acer_wmi" | sudo tee /etc/modprobe.d/acer-wmi.conf
0

I had the same problem, but with neon kde. I solved it by installing kde neon based on ubuntu 18.04 and everything works fine. To do this you must enable the legacy mode option and disable secure boot. As additional information the nvidia drivers work perfectly with this configuration.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.