0

There is an issue with Solaris 11 machine and it boots automatically to the single user mode.We can see the error message "nfs mount: : RPC: Rpcbind failure - RPC: Unable to receive". The machine is a LDom . I booted through OS Image and found that there was an entry in vfstab corresponding to the same. It was removed and tried to start the server again but still the same.enter image description here

I cross checked and there was no entries in dfstab.As in attached image we can see that the network milestone is maintenance mode.

Kindly guide me what further investigation and action need to be taken as this is an critical server and need to solve the issue asap.

Kindly let me know if any further info required.

  • 3
    Please do not post images of text. Copy the output here. – grochmal Oct 12 '16 at 21:22
  • 2
    Do the two logs mentioned the in svcs output show anything specific? – Mark Plotnick Oct 12 '16 at 22:02
0

First, your issue is that there appears to be no network interface configured or working. It appears net0/v4 is set to pick up an IP via DHCP, but didn't get one.
Did you check the log file: /var/svc/log/network-physical:default.log or /var/adm/messages?
ipadm show-addr or even the legacy ifconfig -a might shed some light as to what is going on. Since you note that it's a LDOM, perhaps a configuration was changed on the control domain? Or some other maintenance activity? Have you looked at the DHCP server?

Not completely following where you're going with your NFS troubleshooting. Since it's a Solaris 11 box, the dfstab should have told you it's deprecated and that you should use the share or zfs commands to share NFS filesystems. Just running share should tell you what the server is trying to share out. But you also mention the vfstab which makes me think it's trying to mount a NFS filesystem as a client.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.