1

I purchased a 32" HP Pavilion monitor for use with my desktop running Linux Mint 18 and an NVidia GeForce GT 730 graphics card. The only connections on the monitor are HDMI and display port; my graphics card only has an HDMI port.

When I initially connected it, it was unable to display the monitor's native resolution of 2560 x 1440, instead maxing out at 1920 x 1200. My card should be able to support this native resolution according to its specifications I've spent the better part of the last 3 days trying to resolve this issue. Thus far, I have tried the following:

1) The NVidia drivers provided in the mint repository.

2) The latest version of NVidia's proprietary drivers from their website (which was quite a process in and of itself, disabling X and nouveau.

3) Disabling the card entirely and using Intel's integrated graphics (this does not seem possible given my motherboard configuration). However, my laptop which uses Intel Integrated Graphics was able to display the monitor with its native resolution without any issues.

4) Manually editing the resolution inside of NVidia's X Server settings (this just stretched out the 1920x1200 resolution).

Has anyone been able to successfully configure a higher resolution with an NVidia graphics card? I've heard rumors that NVidia has capped the maximum allowable resolution on Linux machines, but this seems a bit absurd.

Any advice at all would be greatly appreciated. The next step involves either purchasing a new graphics card or switching to Windows.....

  • Is this still an issue for you? Also I've noticed that hardware behaved differently for me on a livecd boot of mint vs. an install off that same disk and same hardware - have you tested with other live media? – ivanivan Nov 29 '17 at 1:46
  • @ivanian It turned out that my graphics card set a limit on the refresh rate which made it impossible to achieve the desired resolution. I ended up purchasing a more powerful graphics card which resolved the issue. – Will Dec 2 '17 at 22:50
1

I've got a similar setup on my other computer so it can be done, although I use the Display Port connection, not HDMI, which may make a difference. Missing resolutions seems to be a common problem, though. I also don't know whether this is just a command line version of what you did in the Nvidia GUI, but its only a couple of commands..

firstly use the command cvt 2560 1440 to find out the 'modeline'. I get something like:

# 1920x1080 59.96 Hz (CVT 2.07M9) hsync: 67.16 kHz; pclk: 173.00 MHz
Modeline "1920x1080_60.00"  173.00  1920 2048 2248 2576  1080 1083 1088 1120 -hsync +vsync

where the second line gives the information about the display (mine has a max of 1920x1080, obviously...)

from the second line, everything after Modeline needs to be copied into the command, like the following for my example:

xrandr --newmode "1920x1080_60.00"  173.00  1920 2048 2248 2576  1080 1083 1088 1120 -hsync +vsync

then if you find the name of the display output, by looking at the output from xrandr and take the newmode info too and for my example I'd get:

xrandr --addmode DVI-I-1 "1920x1080_60.00"

while yours may be xrandr --addmode HDMI1 "2560x1440_60.00"

If this has worked you may now get the option to change your resolution and if that worked you at least know its possible. if it doesn't, any changes will be lost at reboot anyway..

I made use of this tutorial from the mint website which then also covers how to make it permanent, but rather than using xorg.conf your login manager could probably rerun the above, which appears to be desktop dependant.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.