0

Since today morning the display is black (nothing happened, i.e. this happened out of the blue). While I could boot into Linux (I'm running Linux Mint 17 and Windows 7 as a Dual boot system), I tried to fix the display via hard reset. Since then, I am unable to boot into anything.

I've booted from a Mint 17.1 USB stick and tried the boot-repair tool, but to no avail. The two problems combined -- unable to boot, and display not working (maybe some hardware issue?) -- are pretty tough to deal with for me.

The pastebin from boot-repair is here: http://paste2.org/JOm86BFH

The thing I gather is that "The sda5 (Linux Mint 17.2 Rafaela) partition is still full. This can prevent to start it (e.g. you may get a Power Manager error)." but I don't think that this is the issue.

All help is greatly appreciated!

0

Don't use this Boot-repair again. You have installt grub for the wrong arch. /boot/grub/i386-pc/core.img but yor grub-entry says Linux Mint 17.2 Cinnamon 64-bit, 3.16.0-38-generic Take the Medium you have installt your system. It mußt be the same Arch. You have to create /mnt/dev and /mnt/sys /mnt/run and /mnt/proc /mnt/etc/resolv.confin the Live-Session. Next steps

  1. sudo mount /dev/sda5 /mnt

  2. sudo mount --bind /dev /mnt/dev

  3. sudo mount --bind /sys /mnt/sys
  4. sudo mount --bind /proc /mnt/proc
  5. sudo mount --bind /run /mnt/run
  6. sudo mount -o bind /etc/resolv.conf /mnt/etc/resolv.conf

sudo chroot /mnt /bin/bash Now you are in your System. sudo apt-get clean To make some place on your harddrive. df -h;df -i shows you how much place and how much inodes are free.

This slay every wrong grub-package. dpkg -l | grep grub | awk '{print $2}' | xargs sudo apt-get install --reinstall -y Attantion apt install at once without any request. sudo apt-get install --reinstall linux-image-3.13.0-24-generic linux-image-extra-3.13.0-24-generic

  • thanks for you answer! I tried it, but it didn't work. – user194508 Oct 12 '16 at 10:10
  • pressed enter too quickly. I did install Mint 17.2 on the Stick (I had 17.1 before), and ran boot-repair again because it did not mount any of the disks. However, now I can't even boot from the USB Stick! Since the display doesn't work (something with the light), I can't see anything now. Is there something I can do at this point, or should I have the hardware repair, i.e. also the harddrive? – user194508 Oct 12 '16 at 10:12
  • What errors? can you post them? show df -h;df -i And backup your data for sure. – user192526 Oct 12 '16 at 10:15
  • I can't tell you now, unfortunately -- I was too damn impatient. Now I can't even boot from the Stick! I can get into the BIOS, but that is about it. – user194508 Oct 12 '16 at 10:17
  • After the Thinkpad screen, I get 2100: Detection error on HDD0 (Main-HDD) Press ESC to continue So I continued and can boot from the USB now. I paste the output from your commands shortly. – user194508 Oct 12 '16 at 10:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy