1

I just installed mint and it doesn't show wireless connections, the driver is ticked on.

Also when I try to do rfkill list nothing show up.

Any idea on how to fix this?

Maybe I need to get the drivers for this laptop somehow?

I did make sure that the wifi is on in this laptop (HP G62), I also just had an ubuntu install and wifi worked there right from the start.

Edit:

lspci -nn | grep 0280 output:

02:00.0 Network controller [0280]: Ralink corp. RT3090 Wireless 802.11n 1T/1R PCIe [1814:3090]

Edit2:

To make it even more strange, when I load the live usb version, I do get wifi networks to show up at the bottom...

enter image description here enter image description here

enter image description here

  • 2
    Please edit your question and post the output of running this command in a terminal: lspci -nn | grep 0280. – terdon Oct 11 '16 at 11:13
-1

I did a complete erase and reinstall and ticked the "install third party stuff" this time and now it works.

Maybe it happened because I had ubuntu before installing mint over it.

I hope mint won't try to burn my laptop with 100% CPU all the time like ubuntu did.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.