I have installed Ubuntu Gnome on my Dell XPS15 9550. I have issues with the suspend mode. Whenever I close the lid, and then open it again (after a few minutes, to ensure the notebook went into suspend mode), the notebook turns back on, but the screen stays black! Only solution is always to hard reset the notebook.

I recently installed the 4.4.8 kernel, but it didn't changed anything.


  • CPU: Intel 6700HQ (skylake)
  • 16GB RAM
  • Intel integrated graphics
  • Nvidia 960M dedicated graphics card

I have also installed Fedora 24 previously, and encountered the same problem. I assume that it has to do with the graphics card(s), maybe optimus bug, but I am not sure.

EDIT: I tried to login after I opened the lid (because only the screen turns black, but the notebook still works). So i managed to log in, trough the black screen, and opened a terminal with the shortcut and typed reboot. Success! The notebook restarted. This leads to the conclusion that only the screen stays black, but the OS is operating normally after waking up.

  • I have the same problem, Ubuntu Gnome 16.04 on Dell optiplex 9020, please come back and add an answer is you find a solution. Commented Nov 10, 2016 at 8:08
  • @JuanmiRodriguez I also tried out Ubuntu Gnome and came across the same issue again... I think it has to do something with the graphics driver, but I couldn't figure it out yet.
    – bajro
    Commented Nov 10, 2016 at 9:51
  • I updated the kernel to 4.7.4 in case this bug was related to bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-amdgpu but It didn't help in my case I keep getting the blank screen after wakeup, no responsive keyboard (although this my be because it is a wireless keyboard?) Commented Nov 11, 2016 at 14:49
  • @JuanmiRodriguez as you can see in my posting, I am able to control the OS with my keyboard trough the black screen...so everything works..It appears like the driver of the graphics card just don't turn on after the os wakes up from suspend mode...although all other components work. So the problem has to do something with the graphics drivers or maybe it is the kernel but I doubt it.
    – bajro
    Commented Nov 11, 2016 at 15:37
  • @JuanmiRodriguez could that be a Dell related bug? I mean a lot of people which are using Dell notebooks are also encountering the same problem? But that would be ridiculous!
    – bajro
    Commented Nov 11, 2016 at 15:40

1 Answer 1


I had a similar problem, there was an option in my BIOS menu for something along the lines of Open Lid Resume = disabled

I enabled the option and it solved the issue. I was using Fedora on an Acer.

@Bajro, are you able to change TTY?

  • Ok I will take a look at my BIOS settings but I think that I don't have such options in my BIOS. How do you mean change TTY?
    – bajro
    Commented Nov 22, 2016 at 16:56
  • 1
    Sorry for the late reply, I mean holding ALT+F2 or ALT+F3 Commented Nov 24, 2016 at 0:37
  • If you mean changing it while the screen is black, the answer is yes. As i mentioned before, only the screen stays black but I can operate normally with the OS
    – bajro
    Commented Nov 24, 2016 at 12:16

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .