1

Intro

Okay, this question was initially posted with hints that /etc/skel might be part of the issue. I have since removed the contents of /etc/skel, tried again and the issue still persists.

As I said in the initial post, I don't usually use multiple users on systems with graphical environments so I probably look like a total tool and I hope you can forgive the ignorance.

The Problem

When creating a new user using useradd -m -G client newuser I expect that user to login, through SDDM, and gain access to a graphical desktop environment just like the initial user can. However, when logging in with newuser it just drops to a non-graphical shell.

The Question(s)

Why is this happening to me? What have I missed?

I'll likely need to provide more info and config etc. Let me know where I should start.

Edit 1: Couple of errors to keep you going

When running startx after logging in as newuser I receive the following:

Only console users are allowed to run the X server

When running startxfce4:

X server already running on display 0:0

Another session manager is already running

This is despite logging in straight from boot so I know no other sessions are currently active.

Edit 2: The exact issue and answer

So, in all of my infinite wisdom I forgot to grep through the files for hardcoded filepaths.

There were loads. A monumental amount. Just about every file. Thanks to the link posted by C.W. below I remembered how to grep and sorted out the issue quickly with the following command:

cd /home/newuser && grep -rl 'testuser' . | xargs sed -i "s/testuser/newuser/g" 

Is 10 a.m too early for a drink?

2

I have read your unedited post some hours ago and wasn't able to answer because i was at work. The solution for the cloned config files is maybe found here at the xfce forums.

On your recent problem: Did you add exec startxfce4 to a xinitrc-file at the user's home directory? In this case startx and xinit will execute it from there. Otherwise startx will run the default /etc/X11/xinit/xinitrc.

  • The default xinitrc file is being called as you say. Just tried running both startx and startxfce4 from the terminal and received the errors I've edited into the end of my post. – I_GNU_it_all_along Oct 12 '16 at 8:16
  • 1
    I'm trying so hard not to scream the bloody office down right now. It was so obvious. Will add the exact issue to the end of my question but it was somewhere in your link that got me through. Thanks bud. – I_GNU_it_all_along Oct 12 '16 at 8:53
1

It seems you have forgotten to give the new user a /home.

useradd -m  -d  /home/newuser -G client newuser 

and give him a password passwd newuser

  • -m gave it a home directory in the default location i.e. /home/newuser – I_GNU_it_all_along Oct 12 '16 at 8:14
  • It depends what is in /etc/default/useradd I my case # The default home directory. Same as DHOME for adduser # HOME=/home It is comment out, so I have to use the -d option. – user192526 Oct 12 '16 at 8:37
  • Ah right, no bother. – I_GNU_it_all_along Oct 12 '16 at 8:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.