3

I'm trying to install Arch Linux on a dual boot (overwriting a root partition that previously had Fedora). I connected to WiFi easily enough on the installation USB but can't manage to on the real installation.

Some things worth mentioning:

  • On the USB the interface was called wlp2s0b1. This doesn't seem to exist on the installation
  • I installed dialog, wpa_supplicant, wpa_actiond and iw through chroot from the USB (on the installation)
  • ip link doesn't show anything that starts with a w, only lo and enp1s0. On the USB it had a third thing, wlp2s0b1
  • iw dev returns nl80211 not found.
  • wifi worked fine on Fedora
  • I have run systemctl enable netctl-auto@wlp2s0b1.service. When run without sudo it returns Failed to enable unit: The name org.freedesktop.PolicyKit1 was not provided by any .service files. When run with sudo there's no output, but wifi still doesn't work.
  • ip link set wlp2s0b1 up returns Cannot find device "wlp2s0b1"
  • @GAD3R asked for the output of lspci -knn | grep Net -A2 so here it is:

    lspci: Unable to load libkmod resources: error -12 02:00.0 Network controller [0280]: Broadcom Corporation BCM4313 802.11bgn Wireless Network Adapter [14e4:4727] (rev 01) Subsystem: Broadcom Corporation Device [14e4:051b]

I'm completely lost and would appreciate help getting my wifi working.

closed as off-topic by Anthon, HalosGhost, Jeff Schaller, Archemar, GAD3R Oct 29 '16 at 18:51

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions describing a problem that can't be reproduced and seemingly went away on its own (or went away when a typo was fixed) are off-topic as they are unlikely to help future readers." – Anthon, HalosGhost, Jeff Schaller, Archemar, GAD3R
If this question can be reworded to fit the rules in the help center, please edit the question.

  • 1
    Please edit by adding the output of lspci -knn | grep Net -A2 – GAD3R Oct 10 '16 at 9:52
1

To get the wifi working you need to install the broadcom-wl-dkms package:

Description :

Linux® STA 64-bit driver

These packages contain Broadcom's IEEE 802.11a/b/g/n hybrid Linux®® device driver for use with Broadcom's BCM4311-, BCM4312-, BCM4313-, BCM4321-, BCM4322-, BCM43224-, and BCM43225-, BCM43227- and BCM43228-based hardware. There are different tars for 32-bit and 64-bit x86 CPU architectures. Make sure that you download the appropriate tar because the hybrid binary file must be of the appropriate architecture type. The hybrid binary file is agnostic to the specific version of the Linux® kernel because it is designed to perform all interactions with the operating system through operating-system-specific files and an operating system abstraction layer file. All Linux® operating-system-specific code is provided in source form, making it possible to retarget to different kernel versions and fix operating system related issues. NOTE: You must read the LICENSE.TXT file in the lib directory before using this software. Support questions for the latest version of these drivers may be directed to linux®-wlan-client-support-list@broadcom.com.

BCM4311 , BCM4312 , BCM4322 , BCM4313 , BCM43224

pacman -S broadcom-wl-dkms

Unload conflicting modules:

modprobe -r b43 ssb bcma

Reload the wl module:

modprobe -r wl
modprobe wl

Broadcom wireless on Archlinux

  • @TheInitializer did it work? – C.W. Oct 11 '16 at 17:54
  • @cw tested and work fine under bcm43142 , waiting @TheInitializer to confirm it. – GAD3R Oct 12 '16 at 8:36
  • @cw welp I tried doing some things myself and ended up completely screwing my entire system up. This question is kinda "on hold" until I fix that. In the meantime you can help me with my new problem at unix.stackexchange.com/q/316846/194205 – TheInitializer Oct 22 '16 at 3:11
  • 1
    It seems like an intelligent answer though so I'll upvote it – TheInitializer Oct 22 '16 at 3:23
0

I ended up just deleting the entire partition and reinstalling. Works perfectly now

-1

Many firmware images are provided by the linux-firmware package which is installed by default, but you maybe need to install your cards driver manually.

From the arch wiki: To check if the driver for your card has been loaded, check the output of the lspci -k or lsusb -v command, depending on if the card is connected by PCI(e) or USB. Then check kernel messages for firmware being loaded with dmesg | grep firmware. If the kernel module is not loaded go on to section Installing Driver.

  • The lspci -k command shows my network controller, but only two lines: Network controller and Subsystem. I remember there being two more lines on the USB – TheInitializer Oct 10 '16 at 13:09
  • would be great to see a screenshot of your terminal – C.W. Oct 10 '16 at 13:29
  • I don't have a DE and don't think you can take a screenshot in TTY - plus I don't have wifi to upload it with – TheInitializer Oct 10 '16 at 15:21
  • How are you posting here then? Mobile Device? – C.W. Oct 10 '16 at 19:07
  • Yeah, I'm using a phone. – TheInitializer Oct 10 '16 at 19:11

Not the answer you're looking for? Browse other questions tagged or ask your own question.