I saw an answer here but when I tried it with dnf it says packages does not exist. I'm having the sample problem when I try to run videos in my built-in fedora 24 video player (I'm new to linux btw)

Any suggestions to solve this ?


Please install the below required packages using yum to resolve your isssue.

Enable the rpmfusion repository.

yum localinstall http://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-24.noarch.rpm 
yum localinstall http://download1.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-24.noarch.rpm

yum -y install gstreamer-plugins-bad gstreamer-plugins-bad-free-extras gstreamer-plugins-bad-nonfree gstreamer-plugins-ugly gstreamer-ffmpeg

yum -y install gstreamer1-libav gstreamer1-plugins-bad-free-extras gstreamer1-plugins-bad-freeworld gstreamer1-plugins-base-tools gstreamer1-plugins-good-extras gstreamer1-plugins-ugly gstreamer1-plugins-bad-free gstreamer1-plugins-good gstreamer1-plugins-base gstreamer1


yum -y install ffmpeg


yum -y install mencoder

ffmpeg2 theora

yum -y install ffmpeg2theora


yum -y install mplayer

Play dvd

yum -y install libdvdread libdvdnav lsdvd libdvdcss
| improve this answer | |
  • 2
    Thank You sir. It worked perfectly. Actually what I did is ONLY running the 4 Enable the rpmfusion repository commands you provided. I had already installed ffmpeg before. So the remaining 4 commands of your post have not been runned. And it works. Conclusion : Enable the rpmfusion repository commands and ffmpeg installation did the job for me. Thank you – Jason Krs Oct 8 '16 at 20:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.