0

I was installing linux headers with pacman -S linux-headers and was asked which provider I wanted.

[slava@mowgli Downloads]$ sudo pacman -S linux-headers
:: There are 12 providers available for linux-headers:
:: Repository core
   1) linux310-headers  2) linux312-headers  3) linux314-headers
   4) linux316-headers  5) linux318-headers  6) linux41-headers
   7) linux44-headers  8) linux46-headers  9) linux47-headers
   10) linux48-headers

I ended up choosing the wrong one, so I re-ran the command to change for another. I expected it to ask me which I wanted before re-installing but it did not, it skipped the the "Procceed with installation Y/n".

How can I get this choice again?

  • Are you sure that you're using Arch Linux and not a derivative? Please post the output of /etc/pacman.conf. – Libre Arch Oct 8 '16 at 16:31
  • @sixpointzero Am actually using manjero xfce, but pretty stock. pastebin.com/raw/fwwbGNUz – Slava Knyazev Oct 8 '16 at 20:39
  • Well, you should've used the manjaro tag instead of using the arch-linux tag. – Libre Arch Oct 9 '16 at 0:55
  • Have you tried to remove linux-headers (pacman -R linux-headers) and reinstall it afterward? – cylgalad Oct 9 '16 at 8:03
  • @cylgalad Yes I did. One of the first things that I tried. – Slava Knyazev Oct 9 '16 at 20:44
0

This sounds odd. But perhaps try to install using the --confirm option.

From man pacman:

 --confirm

    Cancels the effects of a previous --noconfirm.

But if you didn't run the previous command with --noconfirm this should not have happened.

  • Nope, doesn't change anything. – Slava Knyazev Oct 8 '16 at 20:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.