The interesting thing is that the speakers on my computer work just fine. However, if I plug in my headphones, no sound comes out. The computer is a 2011 21.5 inch, i5 IMac, the specs of which can be found here.

Solutions Attempted:

  • Adding options snd-hda-intel model=generic to my /etc/modprobe.d/alsa-base.conf and restarting. This did not fix the problem.

  • Opening up the alsamixer command in terminal and making sure that my headphones aren't muted there. They were not muted. Headphones not muted.

  • Adding a Fedora 24 partition to my system. I am not able to use my headphones in that partition either.
  • Are the headphones, and the headphone jack on the PC, both known to work? – agc Oct 9 '16 at 3:49
  • @agc Yup. Before booting up linux mint they worked without issue on Mac OS 10.11. They continue to work well if I switch over to my OSX partition. – FabulousGlobe Oct 9 '16 at 3:59

I get that it might no longer be relevant for you, but for other people coming running into this problem, I've had the same, took me days to figure out, but now I have got a very simple solutions that works well (I've reinstalled ubuntu so had to do it all again and kinda know the drill now):

This fix should work for every 2011 iMac 27 and 21 inch alike:

first open up terminal and enter:

sudo nano /etc/modprobe.d/alsa-base.conf

and add to the last line of the file:

options snd-hda-intel model=imac27_122

control+x - y to safe and then do the same in:

sudo nano /etc/modprobe.d/sound.conf

and again add to the last line:

options snd-hda-intel model=imac27_122

close and save it again, and reboot :)

(you have to add the iMac27_122 to both of the files or it still does nothing, though you might have changed one of the 2 already following other peoples instructions, I have to do this for every linux version I install, and I've already tried a few, none of them allow sound through the headphones on default)

if after this it still doesn't work type in terminal (don't undo your previous changes): alsamixer and unmute all the muted channels with "M"


I see your Auto Mute is enabled. Had this problem once and I switched that to Disabled. Worked after that.Although now I have a new problem after trying to install Pipelight as an alternative to Silverlight.So if anyone has any solutions beyond this that would be great.

  • I tried turning off Auto Mute and restarting, but the issue still persists. However, I do appreciate your input very much. – FabulousGlobe Oct 27 '16 at 20:44

I tried digging again, and I found a solution on Fedora 24:

  1. Create the file /etc/modprobe.d/sound.conf

  2. Add options snd_hda_intel model=imac27_122 to the file

  3. Reboot

Note: The subsystem ID is 8086:7270.


FabulousGlobe's answer, which said

  1. Create the file /etc/modprobe.d/sound.conf
  2. Add options snd_hda_intel model=imac27_122 to the file
  3. Reboot

worked perfectly.

For the benefit of anyone new to Linux, step-by-step instructions:

I did this from terminal by using:

  1. touch /etc/modprobe.d/sound.conf
  2. chown yourusername /etc/modprobe.d/sound.conf
  3. Edit the file and add the line mentioned above and save it
  4. Back to the terminal and chown root /etc/modprobe.d/sound.conf
  5. Reboot

I solved the problem in a very simple way

sudo apt-get install gnome-alsamixer

enter image description here

I use it if necessary.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.